Science Direct Problem

Hi there,

After upgrading to 1.0.5 I don't see the address bar icon that allows me to import citation data into Zotero. The upgrade may be irrelevant as I haven't tried to import anything from the site recently so it may be an issue with Science Direct rather than Zotero.

Any idea what is happening?

  • Try clicking Reset Translators and Styles in the Advanced pane of the Zotero prefs.

    If that doesn't fix it, could you post the URL you're trying to use?
  • Tried your suggestion but no luck... There is no particular URL, any article I choose fails to display the address bar icon. :-(
  • There is no particular URL, any article I choose fails to display the address bar icon.
    Can you post one?

    Also, try disabling all your other Firefox extensions.
  • Try this one:

    or this one:

    It's really odd actually, although the articles listed above don't provide an address bar icon I can look at some articles that do. I can't seem to find a common factor that may suggest what is happening...
  • A new version of the ScienceDirect translator has been pushed that fixes this problem. Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs. Thanks.
  • Superb!

    Just tried it out and it works fine. Another example of the responsive attitude held by the Zotero team! Well done!

    Out of curiosity, what was causing the problem?

  • The problem was that the ScienceDirect translator wasn't recognizing URLs of that pattern (/article/...) as scrapeable pages. I think this may have been a new (or very rare) URL pattern on the ScienceDirect site, as I don't remember seeing examples like it before.
  • Not working for me either (I tried resetting trick mentioned above)
  • Same here, I tried updating and resetting my translators, but that did not seem to help:
  • ScienceDirect isn't working for me either. The little icon is there in the address field but clicking it just produces a blank rectangle down in the Zotero area, and nothing is sucked in. I tried resetting translators and styles, to no avail.
  • Hi I have exact same problem as previous poster:
  • I have the same problem as the previous two posts too.

    Now I try to trigger Zotero by exporting the citation as RIS format in ScienceDirect, but let's hope the team fixes the problem soon
  • Thanks to a tip from a user, many translator problems in Firefox 3 such as this one should now be fixed in the latest 1.0 dev build. Zotero 1.0.7 should be out later today with the fix.

    See the linked thread for a temporary workaround.
  • I have installed Zotero 1.0.7. I still get the error message "Could Not Save Item. An error occurred while saving this item" when I try to save to Zotero from the science direct site:
    ... or when I click on a pdf file from this website and try saving the reference from there, such as:
  • ... I tried disabling my other (two) add-ons. This did not help.
  • Evelyn, this appears to be a problem with the translator.

    You won't be able to save into Zotero from the pdf page; however, if you click on the title of the article on the search results page, you should be able to get the information you're looking for with Zotero, until a fix is put into place.
  • Acrymble,
    So far, this trick is working well for all the ScienceDirect journals I've tested. Thanks!
  • I've hit the ScienceDirect problem too - unfortunate as this is the first pdf I've tried to download.

    Acrymble - would we normally be able to click on the address bar icon and put the pfd into zotero? You seem to suggest this might be fixed sometime. BTW if it helps the zotero icon displayed in the address line is a folder - doesn't seem the right thing for a pdf.
  • lakelander, when you are viewing the pdf version of an article on this page, there should not be a Zotero icon in the address bar at all. This is an error with the translator code. Only the description page and the search results page should have an icon.
  • Thanks Acrymble.

    I am gradually getting up to speed on zotero. I think part of the problem I had might also have been due to a simple 'gotcha'. I normally go to ScienceDirect and other journals via a link from my institutional library, and SD opens in a new window within the library browser window. The address bar still refers to the library, not SD, and if you click the save to zotero icon you get the translation issues error box.

    Going 'directly' to SD journal pages is fine. A "gotcha!" list in the FAQ might be a good idea.
  • Hallo

    The sciencedirect site constantly gives the "could not save item" message. I saw that yesterday the site was upgraded, could this be the problem? Is anyone working on it? Can it be manually fixed?
  • I can confirm that the translator seems broken after site update. Unfortunately they didn't give us a heads up. sigh.
    We're looking into it.

    As a workaround, Zotero will automatically import RIS exported from Science Direct (see the link at the top left in SD.)

    Dan, please make this or a similar thread sticky.
This discussion has been closed.