Zotero 1.0.7 Update DESTROYS ALL library entries

Well, Zotero updates have been flawless in the past, and so I had no trouble clicking to update to 1.0.7. I'm using Firefox 3.0.1 -- which is much worse than FF 2.x, IMO.

Anyway, after the Zotero update ran and I re-launched Firefox, ALL of my collections and my library are EMPTY. They're all gone.

Yes, I have a backup -- because I use EndNote as my main production software for managing bibliography data, since that's not really what Zotero should be doing, in my view. (It should collect and organize and let real software do the rest.)

Anyway, DO NOT UPDATE ZOTERO without BACKING UP your data.

If you, too, already did...oops! Your data is gone.
  • Please don't spread ominous warnings in our forums if you don't know what you're talking about. If there's a problem, just ask your question, and we'll do our best to help you.

    Upgrading to 1.0.7 has no effect whatsoever on your data.

    First, try disabling all your other Firefox extensions, and see if that fixes the problem. If that works, re-enable the other extensions one by one until the problem reoccurs, and then let us know what the conflicting extension was.

    If disabling all other extensions doesn't help, send in an error report using Report Errors under the Actions (gear icon) menu and post the Report ID here.
  • I would have to say this is not an ominous warning. The darn thing is behaving like malware now. It removes control of file naming from the user. That is unacceptable. Indeed it is changing filenames on my machine. Without my explicit permission ,I find that almost intolerable.

    It makes experimentation or forgetfulness fraught with error. If I made a mistake on the older versions I simply changed the preferred directory and changed filenames about or took the needful from a back-up. Can't do that now. True, the old sqlite files are there as zotero (xnumber).sqlite but it simply will not allow you to simply delete and change file names. I would like to have the option of rolling back. The previous versions worked beautifully and I have been spreading the gospel. Now, I'll have to use one of the machines I haven't updated, export the library and shift the files. What a pain.
  • grha1l: socvtedu was referring to the 1.0.7 upgrade, which doesn't touch existing data. You're referring to the 1.5 Sync Preview, which has a large data loss warning in bold red letters at the top of the page and instructs you explicitly to use it only with a test copy of your dataset.

    The Sync Preview does modify the directory names in your internal Zotero storage directory on upgrade, if that's what you're referring to, but it also creates a text file in the data directory mapping the old and new names that can be used in a pinch to revert the names (with a single command on OS X or Linux). And, as you note, the pre-upgrade Zotero database is saved in the data directory.

    If you have feedback on the Sync Preview, please post it to the Sync Preview forum, but it sounds like the Sync Preview is not what you want to be running. Either way, it doesn't have anything to do with this thread.
  • Just as an comment from another Zotero user, Zotero 1.0.7 Update works pretty fine for me. NO data was lost with the update and everthing worked perfect!!
  • No. I was talking about 1.0.7 "downgrade" but 1.5 does the same thing. In that case, I expected something like that as part of the sync progress. The problem is with the approved release not the beta. Really, do you imagine that every user is clueless? As I said, the data is not destroyed but you can't get it to function either. Short and sweet, it does not work properly. Please spend your time fixing the problem rather than criticizing people who want you to succeed.
  • grha1l: Then I don't understand the problem you're trying to explain. Zotero 1.0.7 is a small bug fix release with very few changes. There is no database upgrade process—no 1.0 releases since last fall have had a database upgrade process. So if you're talking about the numbered backup databases or "rolling back" then you're talking about 1.5, not 1.0.7.

    Please feel free to explain the problem better on the other thread you started, and I'll try to help you. But socvtedu's issue is about an extension conflict or other error that's just preventing the item list from being generated—it's not any issue with the data itself, which the 1.0.7 upgrade doesn't touch—so this isn't the right thread.
  • I face the same problem. Updated zotero just yesterday and all my entries are gone from my folders. Though it appears having them in the main directory ("my library") won't have them removed somehow. I mistakenly have left an entry there and not put it into a subfolder the other day. This is a very sad behaviour since I am in the middle of my thesis revision at the moment. Glad to be of help to fix this issue if you could tell me what to do.
    I use firefox 3.0.1. with the addons adblock+, noscript, tabs open relative and zotero. No other.
  • Please follow the steps I provided to socvtedu above.
  • Zotero 1.0.7 works fine in my computer, as always.
  • Dan, This has happened to me too, and I'm desperate(!) because I can barely figure out where the data is stored to do backups....meaning: I have no backup of the last 7 months of Zotero data!!!!! There's a lot of research that I have lost. I have searched my computer for all of the zotero files that I know how to look for (ie, zotero*.* and such). What the heck happened???? Everything was there until I installed that d*#@ 1.0.7 update the other day!!!

    I have followed the directions above, disabling other extensions (which are minimal for me), and still no library! Only some library files from Nov. 2007.

    Where the heck did my library go????

    Here's my error report number: 1936773951.

    Please, please, PLEASE tell us what's going on and how to fix it. Months of my work is just gone.
  • I can barely figure out where the data is stored to do backups
    This is FAQ #1. You can also find the data directory by clicking "Show Data Directory" from the Advanced pane of the Zotero prefs.

    It sounds like your copy of Zotero may have somehow switched to a different data directory. Were you using a custom data directory location in the Advanced pane of the Zotero prefs?

    Is all your other Firefox data (bookmarks, history, etc.) up-to-date?

    What are the names, dates, and file sizes of all the files (such as zotero.sqlite) in the top level or your current data directory?
  • Thanks Dan. Since posting, I think I've diagnosed things a bit better.

    So I've found all of the library DATA. What's gotten messed up is the directory. I was using a custom data directory location. All of my Firefox data is completely up to date.

    I've copied all of the library data - including the zotero.sqlite and zotero.sqlite.bak files - back into their "native" home in the Firefox application data file under my user profile. When I restart Firefox and open Zotero (I've redirected Zotero to the same directory under Firefox's folder), it's still giving me the old directory list, even though I now know that all of the library data files are in the Storage folder.

    Is there a way to rebuild the directory files??

    zotero.sqlite 1,445KB modified 7/23/2008 12:33pm
    zotero.squlite.bak " "
  • edited July 24, 2008
    1,445KB is pretty close to an empty database. Was that the file you copied in or was it larger?

    What are the dates and file sizes of the files in the custom data directory?
  • edited July 24, 2008
    I've looked everywhere on the harddrive for other copies of the zotero.sqlite files, and I can't find any. The reason why I know that my library data is intact is by the dates of the folders and images/html files within them - so I know that the data is fine. There are too many to list for you....

    I believe the problem occurred during the update of Zotero. Somehow the directory files from just prior to the update (ie, just prior to 7/23/2008 @ 12:30pm) were wiped out in the custom location and replaced by directory files from the "native" directory location in the Firefox user data folder. I remember an error message as Zotero asked me upon restart to tell it where to find the files. I told it the old "native" location (which had a version of my files that stopped being used back in Nov. 2007), not the custom location where my most up-to-date data was being used/stored.

    So my question is, can the directory files be rebuilt to reflect the actual data in the most up-to-date "Storage" folder (where my most current library data is)?

    If not, I can imagine a laborious manual rebuild, in which I open every single .html file in the data folders and go back to the webpages and re-capture them into a new "clean" library (creating a new directory "by hand"). Any way to avoid this?
  • Zotero doesn't move anything when you change data directories—all it does is change where it looks for the database and storage folder. So there's no way that Zotero could have overwritten a database with one stored elsewhere. If the custom directory location (with the up-to-date storage folder) contains the Nov. 2007 database, you would've had to move it there.

    What are the names and file sizes of all the top-level files in the custom data directory and in the default directory? The storage directory doesn't matter—only the top-level files.
    So my question is, can the directory files be rebuilt to reflect the actual data in the most up-to-date "Storage" folder (where my most current library data is)?
    The "storage" directory contains only attachments—not library data—so no. You need to find the database you've been using.
  • To answer your question about the default directory, the only files are the storage folder, zotero.sqlite, and zotero.sqlite.bak (see the above post for the size and date of last access/writing). In the rush to figure out what had happened, it's possible that I copied over those files (from the default location to the custom location).

    Regardless, since it's not possible to rebuild zotero.sqlite from the images in storage, sounds like I'll be rebuilding by hand. Each one of the folders in storage has webpages, images, etc., and I'll just go back to each of the URL "originals" (if they're still up online) and recopy them into a clean library.

    Oh well.
Sign In or Register to comment.