Zotero LibreOffice Plugin not working with LibreOffice 4 Beta 2

FIY,

I gave LibreOffice 4 Beta 2 a test, but it does not work with Zotero extension. I checked on Linux (Ubuntu 12.10, 64bit) and MacOS X 10.8

In the shell LibreOffice complains that: XDocumentInfoSupplier class is not found.

Best,

Ingolf


Shell output on Linux:
Exception in thread "Thread-8" java.lang.NoClassDefFoundError: com/sun/star/document/XDocumentInfoSupplier
at org.zotero.integration.ooo.comp.Properties.<init>(Properties.java:44)
at org.zotero.integration.ooo.comp.Document.<init>(Document.java:120)
at org.zotero.integration.ooo.comp.Application.getActiveDocument(Application.java:49)
at org.zotero.integration.ooo.comp.CommMessage.execute(CommMessage.java:59)
at org.zotero.integration.ooo.comp.CommMessage.getBytes(CommMessage.java:40)
at org.zotero.integration.ooo.comp.CommServer.run(CommServer.java:60)
at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.ClassNotFoundException: com.sun.star.document.XDocumentInfoSupplier
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
... 7 more
  • edited January 15, 2013
    I can confirm this error, shell output exactly the same as above with a Gentoo amd64 install, libreoffice-4.0.0.1, oracle-jdk-bin-1.7.0.11 and Firefox 18.0.

    /pste
  • edited January 15, 2013
    This is fixed in the version of Zotero LibreOffice Integration on GitHub, and will be fixed in the next release. However, inserting footnotes under Zotero LibreOffice Integration is still broken under LibreOffice 4.0rc1 because of a bug in the LibreOffice RTF filter. This will be fixed in LibreOffice 4.0rc2.
  • Will the next Zotero-release coincide with the release of Libreoffice 4.0 or do we need to download the Github version?
  • The next version of Zotero LibreOffice Integration will be released before the final version of LibreOffice 4.
  • Simon, will this be an update for both Firefox and standalone?
  • yes, a new version of Standalone will be released shortly, presumably with the new LO (and Word) plugin included.
    https://groups.google.com/forum/?fromgroups=#!topic/zotero-dev/zXkArPcizyk
  • Beta plug ins are working good with libreoffice 4 rc 2
    Thanks
  • edited January 31, 2013
    I am currently trying the Beta plugins, too. No problem so far with Libreoffice 4.0 RC2. I am now waiting for the standalone.
  • I just downloaded LibreOffice 4.0 for Windows 7, and updated Zotero to 3.0.12, and updated the LibreOffice-Zotero plugin. It's not working for me.
  • define "not working" please - are you getting the exact same error as above? If not: http://www.zotero.org/support/reporting_bugs
  • Getting HORRIBLE errors here. Is this a LibOffice 4 (Mac) problem?

    On adding or updating (using standalone or firefox) I am getting the nastiest Catch-22:

    A dialog pops up telling me that I have amended the citation (I have done no such thing) and that I can choose to either have it be left untouched and ignored by zotero when it updates (rendering having a citation manager pointless) or select to have it 'revert' to unmodified mode - this duplicates the citation, and does so again and again throughout the document rendering having a citation manager UTTERLY useless and massively defacing my document. I now have around 85,000 words with 600+ citations in total disarray, its now worse than if I'd just done the damn things by hand. Can this be fixed? If so when and how. Please help me.
  • @Danny - we'll continue this in the thread you opened: http://forums.zotero.org/discussion/27704/zotero-endlessly-duplicating-citations-in-document/#Item_1
  • @ Simon and adam. I'm so sorry, but it seems to have righted itself now (phew). When I first installed LibreOffice 4.0, and then re-installed zotero on FF and LO, it didn't give me any error message - it just flat out did nothing. Nothing at all. It acknoledged that I'd clicked on the "incert citation" button (ie, it depressed when I clicked on it), but then nothing would happen.

    That was on my Windows computer at work, and so I was a bit nervous to put it on my laptop, which runs Ubuntu 12.04. But now that it's working at work, I'll try on U12.04, and let you know if I have any problems.
  • (FWIW LO integration is most likely to fail on Windows system because of Java issues)
  • edited February 12, 2013
    Not working here either (ZST + FF on Xubuntu). ZSA gets stuck quering the LO extension. As a FF extension, Zotero is instead working fine. Shall I downgrade to LO 3.6 or do you think it is going to be sorted soon? Thanks for the great work btw.
  • pacard: What do you mean by "ZSA gets stuck quering the LO extension"? Also, are you saying that LibreOffice works fine with Zotero in Firefox but not in Zotero Standalone?
  • Hi Simon, this is exactly what I meant: when I was querying the LO extension from within ZSA, the wizard got stuck (BTW I had the same experience as mgray describes above on LO 4.0). However it worked fine from within FF, that is with ZSA closed. This morning I managed to make it work on ZSA too! The very simple thing I did was to install the Zotero extension from within LO 4.0, that is Tool/ExtensionManager/Add. I hope this will help you find the bug!
  • It seems Zotero is still not compatible with LibreOffice 4.0.1.2, at least not on Mac OS 10.8.2. I'd love to show off Zotero with LibreOffice in Information Skills classes, as an OSS, cross-platform alternative to the university's Endnote subscription. When can we expect Zotero to work with LibreOffice 4?
  • Zotero does work with LO 4 in general. If it doesn't work for you, we'd need more details on what is failing.
  • In LO the Zotero toolbar appears, but has no function - clicking one of the buttons does not trigger any action. Zotero works fine with NeoOffice, and when reinstalling the plug-in I have made sure the paths to both NeoOffice and LO are ticked. I have even uninstalled, then re-installed LO, but to no avail. Help would be very much appreciated!
  • which version of the LO plugin do you have? (check under tools-->add-ons-->extensions in Zotero Standaone or Firefox)
  • Version 3.5.5, and Firefox 19.0.2. Thanks for your help!
  • What version of Zotero LibreOffice Integration is listed in LibreOffice under Tools->Extension Manager? In the LibreOffice preferences, under LibreOffice->Advanced, is a Java runtime environment listed and selected?
  • In LibreOffice, Tools, Extension Manager, the same version - Zotero LibreOffice Integration 3.5.5 is listed.
    When I then click "Check for Updates", the next screen shows "No installable updates are available. To see ignored or disabled updates, mark the check box 'Show all updates'." If I then tick "Show all updates", "Zotero Office Integration" appears with an unticked tickbox next to it, plus a second empty tickbox with no words at all. However, it won't let me tick these boxes, and in the 'Description' it reads: An error occurred:
    Start tag expected, '<' not found
    Line: 1
    Column: 1
    Is this any use? Many thanks, Gerhard
  • hello,
    LibO 4.0.3.3
    Zotero LibreOffice Int├ęgration 3.5.6 is not listed in Extension Manager.

    AOO DEV 4.0.0,
    Zotero LibreOffice Int├ęgration 3.5.6 is listed in Extension Manager,
    but no any toolbar.
    It's a new gestion of Toolsbar whith AOO : Zotero must change the code of the extension as all Extensions whith a toolbar !
    Bests regards.
Sign In or Register to comment.