Zotero Emacs integration?

Is there an existing way to integrate Zotero into the Emacs editor (like the OpenOffice and Word plugins)? If not, are there people interested in developing this functionality?
Unfortunately I am no programmer, just expressing a hope. :)
  • You can use zotero-plain: https://bitbucket.org/egh/zotero-plain/overview

    It's being developed by two of the most vital non-CHNM contributors, Erik Hetzner and Frank Bennett, so it's definitely worth giving a try.
  • Wow, that looks amazing. Thanks!
  • Hi Penyuan,

    emacs work has languished a bit as I work on the restructuredtext/zotero integration, but I use the org-mode integration almost every day. Let me know if I can help with anything.

    (I wouldn't say I'm half as vital as Avram in zotero development, but we can leave that aside :)
  • I've just finished zotexo: http://code.google.com/p/zotexo/.

    If you are LaTeX user or using org-mode as LaTeX exporter then you should definitely try it. Essentially it allows you to pick a zotero collection and associate it with the file. From now on zotexo will continuously synchronize your zotero collection with your local bibfile.

    When you write an article and continuously add papers to your collection it's rather annoying to export it after each update to bibtex. With zotexo you can forget about that.
  • Hi Vitoshka,

    I just installed Zotelo following all your installation instructions but there is still one thing missing. When I want to associate a collection to my LateX file, It gives me in the *moz-command-output* :

    !!! TypeError: Zotero.getCollections is not a function


    fileName: chrome://mozrepl/content/repl.js -> file:///Users/odocao/Library/Application%20Support/Firefox/Profiles/c4a12oxg.default/mozrepl.tmp.js?27
    lineNumber: 12


    I'm using Aquamacs :

    GNU Emacs (i386-apple-darwin9.8.0, NS apple-appkit-949.54)
    of 2011-10-25 on braeburn.aquamacs.org - Aquamacs Distribution 2.4

    Do you have an idea of where this error could come from ?

    Thanks by advance
  • It is definitely on the java script side. It looks like your zotero is not accessible or is not installed (or may be they changed the name of the function, which is unlikely).

    To debug, toggle M-x zotelo-verbose and try again. Then go to *messages* buffer and copy the exact command which was sent to firefox. You can execute it line by line in firebug console or with moz.el repl directly in emacs.
  • Thanks for your quick answer.

    I tried zotelo-verbose and re-try to associate my bibtex file. I got in *messages*:

    zotelo verbose 't'

    zotelo message [Wed Sep 26 12:05:29 2012]
    Moz-command finished

    zotelo message [Wed Sep 26 12:05:29 2012]
    Moz-command finished

    zotelo message [Wed Sep 26 12:05:29 2012]
    ad-Orig-error: No collections found or error occured see *moz-command-output* buffer for clues.
    Sorting environment...
    Removing duplicates... done

    with exactly the same error than in my previous message in *moz-command-output*.

    Unfortunately, I'm not versed in debugging javascript/firefox, what is the command which is executed and which I should give to firebug (I just installed it)

  • It's there above. You have just missed it. It starts with:

    zotelo message [Wed Sep 26 16:15:27 2012]
    Executing command:
    translated as:

    var zotelo_filename=('/home/vitoshka/Dropbox/works/bingo/analysis/tables.bib');
    var zotelo_id = 12931;

    Shall we please move the discution to github development page (https://github.com/vitoshka/zotelo)? Please open a new issue, or just send a personal mail. Zotero forum is not the best place to discuss this stuff.
  • I want to be able to use Zotero with org-mode. I tried to install https://bitbucket.org/egh/zotero-plain/overview into my emacs under windows xp.
    I downloaded this: https://bitbucket.org/egh/zotero-plain/get/c663cd953aa0.zip
    and extracted to my hard-disk, and edited .emacs file as prescribed in

    But, after commanding M-x org-zotero-mode
    this error messages comes out:

    load-with-code-conversion: Symbol's value as variable is void: <!DOCTYPE

    then I cannot continue with C-c z i
    Emacs says C-c z i is undefined.

    What's wrong with my steps? thanks.
  • I don't think the zotero-plain maker(s) read along here, so you may want to contact them directly through bitbucket as well.
Sign In or Register to comment.