Reset to Server - how do I know when it's done?

  • No issue on my end. I did the Restore to Server 11 days ago, but haven't seen an effect, other than the clearing out of the old data.

    I've just turned on automatic syncing - we'll see if that does the trick.
  • All you need to do is sync, which you can do by just pressing the Sync button. There's no indication on the server that you've tried to do that recently.
  • OK, looks like you have an upload going right now, actually. It's 43MB, but we can see if it goes through.
  • So that upload almost went through in an hour, but it hit a snag at the end. I believe I've corrected the issue, so give it another try now.
  • OK, your upload went through. It looks like there was then a complete download from your account—hopefully from a different computer?
  • 99.99% done.

    I now have 11184 items online, 11185 on one computer (my laptop), 11183 on another (desktop at work). It has been in this state for several hours now.

    I don't now what the complete download you refer to may have been. I did not turn on auto-sync on the desktop until after seeing your message. I believe I had the 11183 there already before turning on auto-sync (I have been copying zotero.sqlite between desktop and laptop, awaiting the online database getting updated). Auto-sync on the laptop is apparently how all the data got uploaded. Restore to Server apparently did not work.

    I'll keep checking for the 11183 vs. 11184 vs. 11185 discrepancy to resolve, but clearly we've come a long way.

    Thanks for your help.
  • I got the laptop and online library to agree on 11185 cases, after resolving 41 conflicts manually. Then sync with the desktop produced 41 conflicts, which I resolved manually. Then sync with the laptop produced 41 conflicts, and I stopped. When resolving conflicts, I seem to be presented with a choice between local and remote versions, but it does not seem possible to actually choose - it always seems to take the local. This puts me in a cycle that I cannot seem to complete - each local version overrides the remote (online) version, which then conflicts with the other local version, etc.

    Am I missing something on how to resolve conflicts? For now, I want the laptop local version to prevail, until I get all versions synced. Thereafter, if a conflict arises, I'll want to use whichever platform I worked on most recently.

    Really, really close now, but not quite done.

    Thanks again.

  • When resolving conflicts, I seem to be presented with a choice between local and remote versions, but it does not seem possible to actually choose
    What do you mean by that? You can click the pane of the version you want to keep.

    But see Repeated Conflicts. It doesn't look like you're actually uploading anything after you resolve the conflicts, which suggests that you're just getting a sync error.
  • 2001994284 report id was generated by Zotero on latest sync attempt. Per its instructions, I opened a new dialog under that number and entered details. The Discussion dialog has appeared to discard all these comments - it appears to have 3 empty entries under that heading now.
  • edited November 21, 2012
    There's no need to start a new thread for the same issue.
    Several have generated automated reports and asked that I send them in, using its interface. I have repeatedly, but this is the first one that has generated a report number.
    What do you mean by that? What was happening before?

    Upgrade to Zotero 3.0.10, try again, and provide another Report ID if it fails. Also tell us the exact message that you see when you click the Sync error icon.

    Also, what are the conflicts you're getting? Do you see actual differences between the items?
  • Yay! I now have laptop, server & desktop synced, with 11186 records each and no complaints from sync. What seemed to get me over the hump was accepting remote, rather than local, version of conflicts.
  • Great. Glad to hear it's working.
Sign In or Register to comment.