Openoffice extension: installation failure

Just received my brand new Vista SP1 laptop a few days ago. The machine had office 2003 preinstalled, so I installed Firefox 3.0 RC1, Zotero 1.0.4, and the most recent Word plugin, and for as long as I used that combo my Zotero exprience was by far the best ever.
Things started going bad a few hours ago, when I dowloaded Openoffice 2.4 and tried installing the zotero extension. The installation seems to crash at the point when the extension manager is enabling
At the same time I get an extension manager error reading:

"exceptions.UnicodeEncodeError:'ascii' codec can't encode characters in position
9-15: ordinal not in range(128), traceback follows\X000a C:\\Program
Files\\ 2.4\\program\\ in function
chechForPythonPathBesideComponent()[if 1==os.accedd( path, os.F_OK) and not
path in sys.path:]\X000a C:\\Program Files\\
2.4\\program\\ in function getModuleFromUrl()
[chechForPythonPathBesideComponent( url[0:url.rfing('/')])]\X000a C:\\Program Files\\ 2.4\\program\\ in function
writeRegistryInfo() [mod=self.gerModuleFromUrl(locationUrl)]\X000a", Context=
( @0}}

When I try to start Openoffice, I get the following error messages:

Error loading BASIC of document file:///C:/Users/%CE%98%CE%91%CE%9D%CE%91%CE%A3%CE%97%CE%A3/AppData/Roaming/OpenOffice.org2/user/uno_packages/cache/uno_packages/7703.tmp_/Zotero.oxt/Zotero/script.xlb:
General Error.
general input/output error.


Error loading BASIC of document file:///C:/Users/%CE%98%CE%91%CE%9D%CE%91%CE%A3%CE%97%CE%A3/AppData/Roaming/OpenOffice.org2/user/uno_packages/cache/uno_packages/7703.tmp_/Zotero.oxt/Zotero/dialog.xlb:
General Error.
general input/output error.

...and then openoffice loads.

What is surprising is that although Zotero is not listed in my extensions, there is a Zotero toolbar in Openoffice (one that lacks the Zotero buttons and is consisted of simple text buttons instead, i.e. buttons that read 'Insert citation', 'edit citation', etc.). Of course clicking on them does nothing.
I understand that this is not a common problem, however I would be grateful if anyone could assist.
I don't know whether this has anything to do with the problem, however, I feel I should mention that the guy who sold me the laptop and installed Vista decided to assign a user name in greek lettering which explains the mumbo-jumbo after the folder User. Unfortunately this cannot be changed (at least not easily)

Thanks a lot
  • Judging by the "'ascii' codec can't encode characters" error message, the Greek username might be the issue. This is an OO error that we can't do anything about. You might want to consider creating a new user account and switching to that...
  • To be honest, I was afraid that would be the case.
    Thanks anyway.
  • Hello, I have the same problem but with OOO portable beta 3, I don't have Greek name, and it was working perfectly with OOo 2.4....

    So what's the problem ?

  • Hello, I have the same problem but with OOO portable beta 3, I don't have Greek name, and it was working perfectly with OOo 2.4....
    When you say "OOO portable beta 3", do you mean something based on OOo 2.4 or a beta of OOo 3.0? As far as I know, the Zotero plugin doesn't work at all on OOo 3.0.

    If what you're using is based on 2.4, paste the exact error message you're getting, since it's probably not the same as the one above.
  • Hi, I have my answer.

    Yeah I use the OOo 3.0 beta (wich is something else than 2.4, I assume), in test for portable version. It's not working with Zotero, as you said, so I have the explanation.

    But I guess that it will work in a next version of the plug-in, no ?

  • hello,
    i have the same problem with portable openOffice 3.0 on windows.
    I want to install the recent zotero extension (sync preview) - after having taken some time, openoffice quits with a
    "Runtime Error" abnormal program termination....

    After restarting Openoffice, the only sign of zotero is its toolbar, but with text labels as buttons instead of symbols. Zotero is not listet in the Addons window nor can i find it in some macro libraries...
    So there seems to be no way of cleaning up!?
    But instead of cleaning up i would want to install it correctly :-)

  • tried several times, but still no luck.
    it doesn matter if i select to install it only for me or for all users.

    But here is the exact error message:
    Microsoft Visual C++ Runtime Library
    Runtime Error!

    Program: ...s\OpenOfficePortable3\App\openoffice\program\soffice.bin

    This application has requested the Runtime to terminate it in an unusual way.
    Please contact the application's support team for more information.

    So it seems that this is more related to Openoffice itself than to Zotero's plugin?

    greetings mmoole
  • hurray!
    it seems i just found out what was missing...

    I am working with openoffice portable 3 dated december 2008.

    after reading
    i tried that... but it didnt change anything! After some time, i figured out that the files should go into

    but most of them are already there! Nevertheless copying the rest of the list from the post cited above did the trick, eventually. so you need an older version of openoffice portable that has these files, or just take a local installation.

Sign In or Register to comment.