Error report: 299875012

My attempts to sync are now failing. This occurred after I had a number of citations and one (possibly more) attached PDF file. I have run version 2.1.10 on Firefox 6.0.2. I use zotero storage. I do not have zotero set to sync automatically, rather I hit the sync button to start the process. When I do so I get the error (I believe that it is related to syncing/uploading an attached file, though I wouldn't be able to tell which one). Report ID: 299875012
  • What's the error?
  • I'm not sure how to describe the error in more detail. The sync fails, the red exclamation point icon appears, and the above report ID is generated.
  • What's the message you see when you click the sync error icon, before you report it?
  • File upload failed. Please try again.
  • It may just be an intermittent error that will go away after you sync all your files, but restart Firefox and provide a Report ID and a Debug ID for a sync attempt that produces the error.

    You can hover over the blue progress bar to see whether it's uploading any files each time.
  • It does not appear to be uploading any files, as the hover returns the information of: progress 0%; downloads: none; uploads: __kb (0/4 files). I doubt that this is an intermittent error, or related to the network/internet connection as it has been occurring for about a week, initially at work, then home, then a hotel in Canada, and now back at work.

    Debug ID: D2042212497
    Report ID: 2028265303
    Error message: File upload failed. Please try again.
  • Are your system clock and time zone set correctly?

    Unfortunately we're not getting a helpful error message in there from Amazon (which Zotero File Storage uses):
    We encountered an internal error. Please try again.
    This would appear to be something specific to your system or the files you're trying to sync, though, as no one else has reported it. If you provide a Debug ID that covers a few sync attempts that trigger this error, we'll see what we can figure out.
  • When I tried to sync twice in a row, I got a new error message following the second attempt: You have too many queued uploads. Please try again in 5 minutes.

    Report ID for this error: 636515522
    Debug ID covering both sync attempts: D311228729

    When I tried again after 6 minutes had passed, the error reverted to the original: File upload failed. Please try again.

    Report ID for this error: 837793712
    Debug ID covering all 3 of the above: D204523971

    I don't think it's clock related, I did change my clock and zone with my travels.

    Thanks for your work on this. If you can't find anything, should I just back up my zotero to an external hard drive and try to re-install (either zotero, firefox, or both)?
  • No, this is a server-side error. Reinstalling won't do anything.

    We'll contact Amazon and see if they can tell us why these requests are failing.
  • OK, thanks so much.
  • edited September 27, 2011
    We're discussing this with Amazon, but can you confirm that this is still happening? (I imagine so if this has been going on for a week, but they asked, so I wanted to check.)

    And please do verify that your clock and time zone are both set correctly.
  • Also, please try this with all other Firefox extensions disabled.
  • It was one of the extensions! There had been only 2 non-Zotero extensions active, the Evernote web clipper, which I removed, and Upromise TurboSaver, which I disabled. The next sync attempt worked great, whereas the one I attempted right before disabling the other extensions (and after confirming that the clock and time zone were set correctly) did not work.

    Thank you very much for your effort on this issue.
  • I have also had problems with Upromise TurboSaver and Zotero conflicting. I just installed the latest version of both, hoping that one of them had solved the problem (which I think is more like TurboSaver doing something it shouldn't), but I still had the same problem. So I guess I will generally live without TurboSaver.
Sign In or Register to comment.