Cannot show file

I cannot use the option to Show File when I right click on the attached pdf file.
I am on Mac OSX ML and am running FireFox 15.0

The files definitely exists in my profile: I can use external viewer, or "download" it.
And when I use Adobe to view one, I can see it's stored on the firefox profile.
But I used to be able to "show file" in Finder and the file in its file folder would appear.
I could then easily copy it to where I wanted it to go.
I've just changed computers as well as added profiles so this issue is probably self inflicted.
Any ideas on how to solve it?

  • So I understand correctly that "View PDF" or "View with external Viewer" work for that file?

    If so, provide a debug ID for the attempt to use show file:
  • D1809254025

    Here it is.

  • And that's correct:" view pdf works.
    When I open it in external viewer (Adobe) and do a save as, I can see that the file exists with the random file folder type name it usually has with show file.

    So my data base is OK, just that the command "show file" doesn't work.
  • edited October 6, 2012
    Have you tried disabling your other Firefox extensions? It looks like you have at least a couple Zotero-related plugins installed.
  • Thanks.
    I tried un-installing everything and then re-installed everything.
    That didn't work.
    I can try that again and then just installing Zotero.

    But my problem is that the feature worked fine for me until I THINK when I added a new Firefox profile without Zotero in it. I copied the profile in Firefox and re-named it.
    I don't THINK I changed any settings in the Firefox profile with Zotero.

    My problems are with the original Firefox profile that has Zotero in it.
    I don't know how to reset things to get all the functionality back.
  • Dan,
    I just read a good posting by you for a request on: Feature Requests: "Copy file location" vs "Show file"

    I didn't realize I could drag an attachment OUT of Zotero...stupid me.
    I knew I could drag one INTO it.

    So I can use that instead of the Show File option that I seem to have disabled somehow.

    Would be nice to get Show File back, but I have a better way to do what I used Show File to do.

    So I can live with it.
    Thanks for your help,
  • I tried un-installing everything and then re-installed everything.
    That didn't work.
    not sure I'm following here - did you try disabling _all_ Firefox extension except for Zotero and the Zotero word processor plugin, restarting, and seeing if Show file works.
  • That's correct.
    I have tried several things:
    I have last uninstalled everything (Remove)
    Restarted Firefox
    Then added only Zotero from the website
    Show file did not work
    Altho I CAN View File and I see that its path in/to the database

    I have looked at the Firefox command about:config and did a search for Zotero settings but haven't tried anything because I wasn't sure what I was doing: seemed potentially risky to just play with it

    I use the Show File command to copy the file to another folder, to either send to someone or for later actions: print etc.
    However I just recently found I could drag & drop a Zotero attachment.
    So that does this even better, so I have less of a need for Show File to work now.

    However I really depend on Zotero so I'd like to understand this type of thing if possible.

    I think my troubles started after I made a few more Firefox profiles for myself.
    I copied the default profile and renamed it.
    Then created a few new profiles that were based on that.
    And to make those profiles smaller, I deleted the Zotero folder in the copies: NOT in the original folder tho.
    That one I did nothing to.
    And that still runs Zotero OK, except for Show File not working.
    The one that is the Default one has Zotero in it and it opens up a few pages with various academic pages on it (Home is set to about 8 tags).
    But is a bit slow to open up because of that.
    The other profiles are streamlined and for other purposes: Motorbikes, Finance etc.
    They all seem to work fine.

    It is possible (but unlikely) I did something to the Default folder when I did this: I tried to be really careful not to touch it.
    However at some point the Show File command stopped working.
  • Aha!!!!!!

    Once again I did a remove on everything Zotero in plugins except for Zotero and the Word plug in.
    Then I re-started Firefox.
    Still no success.

    So I restarted the computer: started Firefox with only Zotero and the Word plugin.

    I DID restart the computer in earlier attempts, but not with just the basic Zotero and Word plugins installed: I had other plug-ins.

    So I'll add the ones I think I need back in and see if the wheels fall off.
    But I think will be OK.
    I suspect me adding extra profiles probably upset something in Firefox that needed a restart to come right, but with only the basic Zotero.

    Thanks for your help guys: much appreciated.
Sign In or Register to comment.