Track Changes Compatibility in Word

The incompatibility of Zotero with the track changes feature in Word has held me back from using Zotero for any serious work, as track changes is heavily used when working with several authors on a paper. However Mendeley claims to have fixed this problem in their 1.1 version. As their word plugin was based on the Zotero one (if I remember it right), I was wondering if these changes flow back to Zotero?
  • I don't think so, no - this has so far been very much a one-way street. But maybe their approach can be adopted. From what they say, their workaround is to have the workplugin temporarily disable the track changes feature everytime the plugin refreshes citations and then re-enable it. Maybe Simon could say whether that's a possibility for Zotero.
  • This is already implemented for the next version of our Word plugins.
  • out of curiosity - did that come from Mendeley?
  • No. Mendeley has never contributed any patches back to us, but for the last two years we've used a different codebase (not Visual Basic) anyway.
  • Hi Simon, that is great news!

    I saw the updated plugins were released last week. Is there any way to get the same update with Zotero standalone or do I have to wait for the next beta/release? And how safe is it, should I still be wary of using track changes or should it be safe 100% (or 99%) of the time?

    Btw. I think you guys should really run an announcement or blog post about this, as I know it is one thing that has held many people back from using Zotero.
  • the plugins are independent from the Zotero version you're using - so afaik this applies to the SA and the beta as well.
  • The standalone ships its own plugins and doesn't seem to have any mechanism to upgrade them independently. The downloadable plugins are firefox plugins (which I would need to download and install if that is the way to go).
  • Just a quick update: it all works perfectly now, haven't run into any problems with zotero in combination with track changes in recent zotero versions.
  • @wouterstomp: Sadly, I must disagree, at least with openoffice/libreoffice zotero integration. It's a big pain, really... I'm running into tons of problems to finish my document.
  • if you don't provide any details we can't provide any support.
  • @adamsmith: I was not sure it was solvable, since it is said in the help that Track Changes "is known to cause problems with Zotero integration" (

    I was using LibreOffice 3.6.2, Zotero 3.0.8 and plugin 3.5.3 versions. The document I was editing had track changes active, and comments, but no citations. I started adding citations with Zotero, but when I had around 15 and had added the bibliography the document crashed and closed. Whenever I opened it again I could sometimes add a citation, sometimes not; it would simply leave a field "{Citation}" but not the actual reference. And sometimes it would add the same citation 4, 5 or 6 times at once. Anyway it was crashing every couple of minutes.

    I then accepted all the changes and disabled track changes. The document was still crashing, it not possible to work with it. Then, not knowing what to do, and even when I had the latest version installed, I reinstalled the plugin... and then it worked!

    Nevertheless, this was all after uninstalling OpenOffice 3.4., with which was impossible to work using Zotero for me, and having to install LibreOffice. And anyway I could not use track changes together with references added with Zotero. It's really annoying, since it's vital to my work, and makes me lose a lot of time.
  • wrt to track changes - that should no longer be the case. Note that right after the sentence you quote it says: "(With the most recent version of the plugins this should not be the case any more - to be safe, do still perform this step, though.)"
    Disabling this is only one troubleshooting step if things aren't working correctly - not necessarily the reason. It's highly likely that one of the other strategies suggested would have worked.

    Since things seem to be working for you now, though, I'm not sure how to help you?
  • @adamsmith thanks for the fast reply! Well, things are not working, I still cannot use track changes plus zotero integration. I could finish my document accepting all the changes and stopping to track them, then putting the refs. But now I need to track changes again, so basically my collaborator does it in a copy without field codes for references.

    I did see the continuation in the help page, that this should not be the case anymore... but "should" didn't sound very convincing to me, I thought it was, as it mentioned, a known issue. And I could not find help in the forum regarding this topic. Two members in my group already left Zotero for Mendeley due to this, but I would prefer to stick to it... since I've been using it from the very first beta.
  • we need more precise error descriptions than "cannot use"
Sign In or Register to comment.