first name letter in citation

For some author I get the first name in the in-text citation in word. How may I fix this?

(J. Asplund & Gauslaa, 2008)
  • Check the author field in the right column. Make sure it it set for "two fields," not single. This puts last name first.

    To change, click the little white space that is between the name and the - + signs.

    If this fixes your problem, you will need to change each item that has single field selected.

    If it doesn't fix your problem, please write back!
  • It's already set to "two fields" so that wasn't it
  • and as you see in the example it's only for one of the authors however the second author also have a first name letter in the database
  • which style are you using?
  • It's not style-specific. I'm experiencing this with all (Author-Date) styles
  • can you export the reference you are having trouble with in Zotero RDF and email it to me,
  • I got your email and could not replicate the issue, I will play with a bit more and see if I can. In your email you mentioned
    The same reference can be correct and wrong in the same word-document
    With that noted, and the fact that they worked fine for me we can rule out an issue with the styles and the way the names are formated in your collection.

    When you hit the refresh button do they switch back to normal?
  • They don't turn back to normal. I couldn't replicate the issue in a new document but in that document I can't get it right
  • The problem happens to me if the author uses her first name in a book chapter, but her initials in an article, or her first name and middle initial. If there's any variance, the software works extra hard to distinguish the variants as different authors, I think.

    T. S. Eliot and Thomas Stearns Eliot would each get cited in the text as different people. The only way I can make it stop is to edit the entries to be consistent, which is not what the author or editor intended.
  • I have the same problem here and it happens only in book section. I did not quit understand what the last person did to solve the problem. can someone help with a fix for this.

  • Zotero, and for that matter any other bibliographic software I can think of, simply have no way to know that T. S. Eliot is the same person as Thomas Sterns Eliot as opposed to a different person named Trevor Stanley Eliot.

    For the foreseeable future you will need to make sure that authors are referred to by the same name for Zotero to know that they are the same person.
  • I had this same problem. You can "solve it" by retyping the names in the fields. It's possible that it has something to do with selecting an auto-completion name.
  • Hi,

    I have this problem consistently every time I have several authors with the same last name (using Zotero 1.0.9). I happens with all Author-Date styles. Does anyone know how to fix this?

    Thanks in advance.

  • dnh - that's not a "problem" by most standards it's intended - but if you really do want to get rid of it, look at some instructions on how to modify csl styles:
    (such as here:
    and then simply delete the 'true' from the line
    <option name="disambiguate-add-givenname" value="true"/>
    so that it reads
    <option name="disambiguate-add-givenname" value=""/>
  • Thanks for your answer - as far as I understand, this is only possible in the styles in Zotero 1.5, in 1.0.9 the style files are not directly accessible, or?
  • yes they are.
    Please read the thread on the link cited above, which contains extensive instructions on where to finde them, what to do etc.
  • I've been struggling with this problem for a few weeks now. In all (author-date) citation styles, some of my citations will have first names or initials added to them:

    (John W. Moreau and Sharp 2004) [incorrect]

    when it should be:

    (Moreau and Sharp 2004) [correct]

    I think that this is a real bug in Zotero (more on that later). It's related to having multiple authors with the same last name in the database. First, here is a summary of quick fixes. Just go down the list until the problem goes away:

    1. Change author entries that have no space or a period between the first and middle initials. Ex: "Moreau, JW" and "Moreau, J.W." will cause problems.
    2. Change author entries to add a period after all initials. Ex: changing "Moreau, J W" to "Moreau, J. W." may fix the conflict.
    3. Change author entries for the same author but with different formats. Ex: "Moreau, J. W." and "Moreau, John W." may cause a conflict.
    4. Add middle initials to author entries. Zotero can't seem to differentiate authors with both a first and middle name from authors with only a first name. Unfortunately, this can't always be fixed. Ex: "Moreau, John W." and "Moreau, Myriam" will cause a conflict.
    5. Remove the line <option name="disambiguate-add-givenname" value="false"/> from the CSL style file. Actually, this step should remove the problem altogether, but not everybody knows how to edit CSL files. Here's the real bug in Zotero. It appears that this line doesn't do what it's supposed to do, but deleting it does what it should do in the first place. Also, it appears that the line <option name="disambiguate-add-names" value="false"/> doesn't work either.

    I was able to fix most of my citation issues by the first three steps, and unfortunately it takes a lot of time to edit each entry in the database, especially surnames like Williams and Smith. But in the end there were a few stragglers and I still had to edit the CSL file.
  • I get the same problem. Really annoying...
  • edited July 11, 2009
    I've not tried to reproduce this issue in Zotero myself, and I'm not sure whether there is a bug here. But from a quick look over this thread, it seems to me that people might be getting confused over what CSL/Zotero "disambiguation" is trying to do. It isn't about differentiating authors as persons, but about differentiating works that are known to be different (because they are listed in separate database entries), but would have the same key in the text if only the last name were used.

    (EDIT: I was completely wrong on this. For most publisher styles, the correct thing to do is to attempt to disambiguate all authors that have the same surname and a different given name or initial. That is what current Zotero does. I apologize for any confusion that this intervention caused.)

    I can only speak for the new CSL processor that I am building for vetting and possible inclusion in Zotero, but it is being thoroughly tested, and I am fairly confident that when it adds an author name or initial, it will be necessary to do so. I suspect that a little investigation would reveal where the "unexpected" initials are coming from for many users who are initially thrown by this behaviour. I'll be happy to correspond with anyone who feels Zotero is doing the wrong thing here, in order to track down the source of the behaviour.

    (EDIT: With guidance from other users, I have rewritten the disambiguation code for the new processor so that it does the right thing. There are actually several forms of disambiguation with subtle differences between them -- seven, to be exact -- and the new processor will be able to handle all of them.)

    Frank Bennett
  • I'm having the same issues (first names in citations) and I guess StephenHero is right about the cause.

    When there are differing entries for the same author in the database, e.g. "Smith, R." in one item and "Smith, Robert" in another, or "Miller, S. D." in one item and "Miller, Stephen D." in another, Zotero somehow messes up some of the citations.

    I have spotted this in citations with multiple authors only. Unifying the names of authors of affected citations across the entire collection solves the problem for me so far (but bores me to tears).

    If you're using a word processor plugin and have only a few occurences in your document, you can also manually edit the citations to fix them.
  • On a slightly different issue, what is the best way to handle reports that have no author, e.g., a government report? Do you list the smallest component in the hierarchy as the author and the larger agency as the Institution. Do you leave the author blank? For example:

    Energy Information Administration
    Office of Integrated Analysis and Forecasting
    U.S. Department of Energy
    Washington, DC 20585
  • I have the same problem, seems to occur mainly with books, even after ensuring that it's last name, first name and they are not a single field.
  • @charles - have you read the above discussion about the relevance of same last names, different first names or more importantly different spellings of first names? Is it possible that Zotero is just disambiguating?
  • edited June 8, 2009
    @Adam - I can't see how - it's a single author with no editor listed. Here's an example:

    It always pops up in word as (Martin innes 2003).

    Even changing the first name to M just makes it (M Innes 2003) - translator issue?

    EDIT: - nope you are right - I have another reference with the same author as a co-author - by changing that reference to

    Innes, Martin as well it fixes the problem.

    Thanks guys.
  • I am having the same problem even when all instances of the name are consistent. It happens sometimes but not always (for the same citation in different places in the document) and it comes and goes seemingly at random. It's incredibly irritating. It's a real bug, I'm not confused about disambiguation.
  • huntergatherer,

    My note above about what disambiguation is trying to do was wrong. I apologize for any annoyance caused, and I have edited the post to acknowledge the error and provide a little more info.

    If you're having trouble with disambiguation, I would like to be sure at least that the new processor will behave correctly for you. But to do that, I'll need some data with which I can reproduce the fault. That would consist of:

    - The content of the DB items used to build the cites (just the creator fields should be enough), including all cites in the document that contain the names that are going bad;
    - The style used for formatting;
    - The expected output;
    - The output that you're getting instead.

    Sorry for the burden of this, I know it's a headache on top of the headache you're already struggling with. But I, and the Zotero developers, need to be able reproduce the error in order to pin it down.

    Frank Bennett
  • Hi Frank,
    sorry for the delay in replying. I went back and checked and there were three things that were making it look like the first names were consistent but weren't. One was that I need to use a lot of citations of the form Smith (1997) (rather than (Smith 1997); this is standard in my field) so very often I type the author's name and then use 'suppress author' to print the year. One of the inconsistencies was actually where I'd typed the last name in one place but not another. In another case there was a space in the author's name so the text string was different and I hadn't noticed. The third thing is that it often takes quite a while for the 'refresh' to work (it's a large db and complex document and I'm on a Mac using Word 2007). It can take a few minutes sometimes for everything to update itself and I think I had checked before the field was updated.
    I'll keep an eye out for inconsistencies but in the text document I did to replicate the problem changing the first names (like charlesknight did) solved the issue.
  • Hum it's odd, even where changing names this seems to persist for some reason with entries - I have a Crawford, C. and a Crawford, R. and it wants to add the first name.

    I've been up and down the references and cannot see the problem - I am using the build-in version of Harvard - can someone confirm it's suppose to disambiguate like that as suggested above?
  • if I understand you correctly that's actually what the behavior is for: disambiguating between different authors with the same first name.
    While it can be removed from a style that is intended behavior indeed.
  • @charlesknight Not absolutely sure what you mean by "wants to add the first name", but since it's harvard1, I assume that you mean that it's adding a full name, like "Crawford, Richard". The current CSL processor takes into a account all of the names in all cites in the document, even when they are masked by et al. Could that be the source of confusion?
Sign In or Register to comment.