ISI Web of Knowledge import stopped working

Until a few weeks ago, I could grab citations from a search on ISI Web of Knowledge (Web of Science, specifically). Then, the interface was changed drastically, and it's no longer working.

Has anyone else had this problem? Is this some weird thing were my institution has a customized interface that no one else is using?

And the bottom line, what's the procedure for requesting/creating an updated site translator?

  • Indeed, it looks like my institution has switched to the "new" interface as the default. You can get to it via:
    Looks like I can still get to the old interface, so that's a workaround, but it'd be nice for Zotero to be updated for the new interface.
  • another vote for the new interface
  • Zotero now supports the new Web of Science interface. Please let us know if you experience problems with Zotero's behavior on the site.


  • heyho..

    The "document" icon in the adress-bar does appear when i click the "save to endnote, refman, procite" button on an ISI Web of Knowledge/Science search-results page. Clicking the "document" icon in the adress-bar a red square in the lower right edge of firefox appears, normally saying something like "saving document". but this square stays blank and zotero hangs for a moment (showing the "wait" / "hourglass"-cursor) and imports nothing.

    this happens with several documents i tried to import. I have to export the result as bibtex and then import it to zotero...

    - pan -
  • Can you post some specific items and URLs that fail?
  • This happens for all articles i tried (so far).


    URL of "Web of Knowledge" result-page (shows no zotero-icon in the adress-bar at all - would be nice if it did):

    URL of the "save to endnote, refman, procite" option from results from above
    (shows zotero icon, but doesnt work, as described above):

    (maybe this second link wont work when not visited directly from the "results" page (?))

    This example is the result of a search for TITLE:

    "Long-term effects of ammonium sulphate on Calluna vulgaris"

    in the web-of-knowledge search.

    thanks for your fast reply
  • I did a title search and found the article. The search results page did not work, but I was able to import the item from the individual item page. Can you capture the article from the individual article page?
  • OK..

    i see:

    your individual-item page shows the "WEB OF SCIENCE" tab highlighted
    (kind of navigation bar of the "web of knowledge" page).

    your URL again:

    and works!! (THX!)

    my "search results" link has the "ALL DATABASES" tab highlighted.

    my URL again:

    and doesnt work...

    for some reasons following your link i cannot see the "all databases" tab - only
    "web of science" and "additional ressources".
    maybe thats because im logged in via universities vpn or something....

    so thank you for solving my problem in the first place!

    but i can still reproduce the error i described:
    following your link, clicking on "Save to Endnote, Refman, Procite"
    and then trying to import via zoteros adress-bar icon still fails.
  • Hi all,

    I have been having the same problem with Web of Science. I cannot download a complete page of references, although I do *sometimes* see the folder icon in the url bar. I just get the "Could not save item" message. If I go to an individual record I can download that single item OK. I tried installing the alternative xpi but it made no difference. Unfortunately, I can't try firefox 3 as our system is pretty locked down.

    Is there any fix for this? This used to work fine. For a lot of our users the ability to download complete search pages from web of science/knowledge is going to be a deal breaker I'm afraid.

    Any advice?
  • OK, i think i never said it clearly:

    i never meant a "search results" page with more than one item.
    i always meant the "individual item" page.

    You can have an "individual item" page in "web of science"-tab and (nearly) the same page in the "all databases"-tab.

    In this "all databases" -tab an individual item pages doesnt show any zotero- icon in the adress- bar.
    In the "web of science" tab it does.
    another thing is what jimbotyson says:

    a page with (more than one or only one) search results doesnt show a zotero-icon (or this icon doesnt work). would this icon work one could import multiple results with one click.
  • My first post here, and I'm brand new to Zotero, just installed it today. I love the ability to simply grab a list of references from, for example, IEEE xplore -- it's easy. I'd like to be able to do the same with Web Of Science/ Web of Knowledge. My understanding of what I've read on this forum is that things aren't yet working, other than individual items, is that correct?
    So, count this as a vote toward that idea as well.

    I'm using linux and Firefox 2.004
  • same here with Zotero 1.0.6 and firefox

    Import from ISI Web of Knowledge [V.4.2] does not work: I can't import entire page or single references obtained after searching the Current Content.

    Otherwise, Zotero is great!
  • I have the same problem in web of science ( ZOtero 1.0.6 in firefox

    I did some changes in the translator of web of science (using scaffold) to recognize the page web of Knowledge ( the folder icon now appears) but I didn´t get to import the references from the list.

    I don´t know javascript, so if there are some body knows, please help us.
  • WOS and BIOSIS used to work for me but alas, no more. always trying to get around it - search in BIOSIS but go download articles in different collections (e.g., JSTOR) but often those don't work either (e.g., BioOne, icon is there but the red box appears to say: "Could Not Save Item.... known translator...").

    (caveat: i'm pretty naive about how it really works) but maybe an alternative solution for frequently changing databases, etc is to be able to import the text format from whatever database/collection (e.g., WOS) and some how prompt Zotero to import the citation from notepad?
  • We just pushed out a fix for some of the Web of Science/ Web of Knowledge issues. Your copy of Zotero should auto-update within 24 hours, or you can update manually by clicking Update Now in the General pane of the Zotero prefs.

    To open the preferences pane click the gear icon, this will open the actions dropdown menu. Select preferences from that dropdown menu.
  • What about importing old ISI/PubMed search results from .txt files? EndNote can do that, but I couldn't get Zotero to do it.
  • @olgafinikova, it depends on how those files are formatted. If those .txt files are formatted in one of the supported import formats (For example RIS or BibTeX) it should be very easy to import them.
  • On the whole, Zotero works great with WoK but there's one thing that bugging me. If I search for a paper, then click on the search result to get to the individual reference, the 'save to Zotero' icon comes up. However, if I get to the individual reference for the paper through another paper's 'cited references' list, this icon does not appear.

    For example, this paper

    displays the icon fine.

    The same paper reached through searching the cited references of this paper

    has no icon:

    Zotero seems to recognise 'FullRecords' but not 'CitedFullRecords'. As I said, it's not a huge issue just a little bit annoying when doing literature searches
  • edited August 29, 2008
    Thankyou. I'd just like to reiterate how great Zotero is... It's great!
  • edited September 22, 2008
    Argh! Broken again for WoK? WoS works fine! Only 3 letters different in the URL and it dies (product =...)

    Alright, I installed Scaffold and managed to get it working... the changes I made were to Michael Berkowitz's ISI Web of Knowledge translator.

    Target: (WOS_GeneralSearch|product=WOS) --> (WOS_GeneralSearch|GeneralSearch|product=WOS|product=UA)

    Detect Code: if (doc.title.indexOf("Web of Science Results") != -1) { --> if (doc.title.indexOf("Results") != -1) {

    Works like a charm. Someone who knows what they're doing want to check this out and maybe merge it in?
  • I am having difficulty with WoK as well...

    The only time the Zotero icon appears when I got to the "save to endnote refman procite" page (that in itself seems a bit clunky - but that is another project... as long as it works...)

    But when I click the icon, Zotero just hangs (hourglass) and nothing gets imported.

    I tried implementing the hack from yuletide to no avail...

    Any progress on this?

    (Zotero 1.0.7, Firefox 3.0.4)
  • Thank you Yuletide !

    Your fix did part of the job.

    It looks like the original code was only able to "sense" the results from the "Web of Science" databse. Now, thanks to your fix, Zotero can "sense" the results from other satabases / tabs ("All Databases", "Current contents connect", "Medline"...)...


    It is still unable to import results which are NOT part of the "Web of Science" database.

    For example, there is no way I can import this article from "Medline" :

    Same with this one from "Current Contents" :

    I wish Zotero was able to see the difference. Obviously their structure is different and this causes the import process to freeze.

    Is it possible to "teach" Zotero to distinguish "Medline" articles (product=MEDLINE) , "Current contents" articles (product=CCC), etc?
  • Hi,
    I just wanted to mention that I am also having issues getting Zotero to read the WoK database. I am a new convert and now dedicated follower of Zotero now!
    As for the issues, the icon (notepad looking icon) is visable in WoK items but does not pull data and gives a save error. the link is

    I look forward to new updates and releases. This is an amazing tool, I use it daily in my research (vert paleo). Thanks to all for everything you are doing!
  • I wrote to Thomson Reuters customer support in order to let them know about the problem and they say they would be glad to help improving the ISI Web of Knowledge import filter.

    Here it is (in case it can help) :

    Dear Jean

    Thank you for your response. As we do not support Zotero we can not supply you a solution for Medline and Current Contents in regards to importing. As for us Supporting Zotero we are more than happy if Zotero wants to contact us to enhance their importing tool.

    Best Regards

    Tarnjeet Nandra
    Customer Technical Support Executive
    Global Customer Support
    Thomson Reuters

    Technical Support: +44 20 7433 4999

    --------------- Original Message ---------------
    From: jean-Hugues []
    Sent: 06/03/2009 13:03
    Subject: Re: Thomson Reuters Technical Support Case:TS-00069816:ref:00D3un.50077zwhs:ref:How
    to export bibliograp [ ref:00D3un.50077zwhs:ref ]

    Good afternoon,

    Thank you for your reply.

    Thomson Reuters Customer technical Support a écrit :
    Dear jean-hugues,

    >Thank you for contacting Thomson Reuters Customer Technical Support about the >possible exporting enquiry. I do apologise for the late response but hopefully I will be >able to assist with all your questions.

    >In regards to exporting bibliographical references from ISI Web of Knowledge to >Zotero we do not export to Zotero as we do not support this software. The only way >you can export it is if you save to it to a file and then uploaded onto your software.

    Well, Zotero being widely used by your customers, I think you should take a closer look at the way it works and make sure that the interface used to access your databases is compatible with it. I am convinced that the problem I'm experiencing could be solved easily would your technical staff contact the team in charge of Zotero to identify the source of the problem.

    My problem is that Zotero is able to import bibliographical references
    from the Web of Science database, but it is unable to do so with items
    from Medline and Current Contents. Zotero has been instructed (through
    an import filter) to recognise Web of science references, but not
    Medline and Current Contents'. I guess that it stems from the structure
    of the references from Medline and Current Contents being different from
    that of Web of science.

    Therefore, the import filter just needs to be modified. I'm sure this
    can be done easily provided you get in touch with Zotero's team.
    In regards to exporting from Medline and Current Contents, what issues are you having that does not allow you to export? How are you exporting files?

    >You can either export from the bottom of the results page that gives you the option >to export to any of our Exported Software, e.g "ref manager, endnoteweb and >procite" and also save to "other reference software" which includes "html, plain text >and tab-delimited". Other references software is the option you should use if you >want to export it to Zotero.

    Indeed, another way to get around this problem would be to find a way of saving results to a file and import it into Zotero. I tried that but it
    doesn't work. As a matter of fact, Zotero can't import .cgi files.
    Neither can it import txt files generated by the "save to other
    reference software" option...

    It might come from the parameters from my computer, but I doubt it.
    Did you try it out yourself? Could you do some tests?

    I'm sure this problem could also be ironed out easily. As far as I know,
    Zotero can import the following files :

    MODS, MAB2, MARC, RDF, RIS, Refer/BiblX, BibTeX

    If you added to your interface one or several of those, that would do
    the trick. The more the merrier, eh?
    I'm not a specialist in computer but I guess that it would not be
    difficult at all.
    Think about the benefits for your customers !

    >Let me know how you get on and notify me of the issue that you are having.

    Done ! ;-)

    I really hope that we will find a way to solve the problem.
    Many other librarians, students and professors are experiencing the same

    Please help us out !

    Thanks for time,

    Best regards,

    JH Morneau
  • thanks! -unfortunately, Thomson Reuters is the same company that produces Endnote and has sued Zotero... I wouldn't bet on them actually wanting to be helpful...
  • Thanks for the info, I didn't know that.

    HEY is this me getting mad or did Thomson Reuters do something?

    I just found a way to export into BibTex format for ISI Web of Knowledge !!!!

    Just select some items, then click on the arrow following "Save to other
    reference software" and in the list that opens there is "BibTex" !

    Tried it and it works !

    I may be wrong but I'm pretty sure "BibTex" wasn't on that list before.
    Can someone confirm this???

    Anyway, I'm very glad that I can use Zotero with ISI WOK now.
    If we could export to BibTex from Ovid SP as well, all my problems would be solved and I would be perfectly happy with Zotero :-)
  • Oh no, I was mistaken.

    One can only export into BibTex format from the Web of Science, but not from Current contents nor Medline....!

    It was too good to be true.
    Sorry for that...
Sign In or Register to comment.