sync problem hundreds of conflicts

Hi all,

after upgrading to 3.0 I got suddenly 226 conflicts to resolve during sync.

Because I didn't want to resolve all manually and because I knew that my local repository is the right one I tried to reset my sync to the server.

But although the bib on the server seems to be completely empty (in the online-view) I get the conflicts again as soon as I try to sync again.

Any hint?
  • Including trash?
  • trash is empty
  • I tried it once again:

    First resetting bibliograpy and then syncing again. Same error.
    I made a debug-output: The Debug ID is D810462678
  • What does "resetting bibliography" mean?
  • I guess you mean "Restore to Zotero Server"? (Data in Zotero isn't called a "bibliography" until you actually create a formatted bibliography in a citation style.) Just for future reference, note that, as it says in the preferences, the reset options are not meant for troubleshooting, and they usually just make things worse.

    In any case, from your debug output it looks like what you're getting are file sync conflicts, not data conflicts, and the reset options have no effect on file conflicts. Somehow all the file modification times on your WebDAV server are from December 2010, whereas your local files are (mostly) from 2009. Perhaps you somehow overwrite all your WebDAV files from another computer in December 2010?

    Assuming the files haven't actually changed, we should be able to skip the conflicts, but that's not done currently. We can't fix this on the 3.0 branch, but if you quickly click through all the conflicts once—I believe Zotero should default to the most recent timestamp, so you shouldn't need to review each one—this should go away.
  • I mean "Restore to Zotero Server".

    Yes you're right: all of the sync conflicts are files.

    I will try like you proposed, skipping the conflicts and see what happens.

    thanks a lot.
Sign In or Register to comment.