Adds-on toolbar missing - Zotero not working in my word docs

Hi all,

since a few days my Zotero adds-on toolbar (the one at the bottom of the firefox page) has disappeared from Firefox, and Zotero is not working on my word docs.
I tried to reinstall Zotero but apparently "zotero cannot be installed because firefox cannot modified the needed file".

Do you have any idea what may be the problem?
  • I tried to reinstall zotero but nothing has changed. I also updated firefox, but still nothing...

    Anyone has a clue of what the problem may be?? :(
  • we'd need version numbers of all software (OS, word processor, Zotero) involved.
    This sounds like a permission issue to me, but it's hard to say without more detail. If you can, also provide an error report ID:
  • Something similar happened to me today. However when I open a new window the Zotero button appears on the new page but is missing from the first page I opened.
  • I cannot install Zotero 3.0 on Firefox 10.0.2, OSX 10.7.3, 2012 MacBook Air.

    I get the "cannot modify required file" message.

    Please advise.
  • This is a Firefox message, not a Zotero one, so you might have better luck in the Mozilla forums.
  • This is a bit silly. Zotero is running on top of firefox, so blaming incompatibilities on firefox does not make sense. Anyway, On Firefox 11 Zotero 3.0.3 is completely absent and non-functional (win7-x64).
  • Zotero is running on top of firefox, so blaming incompatibilities on firefox does not make sense.
    jorisb: Yes, it does. Zotero and Firefox are separate pieces of software. We don't make Firefox, and this message is a Firefox error message that's not specific to Zotero. It's their code that's displaying this error, there are reports of it all over the web, and Mozilla has many times the support resources and users that Zotero has. The Mozilla forums are the place to ask about this problem. Trying to debug the issue here would be a waste of your and our limited time.

    If you find a solution, you should certainly post here and let others know what you found.
  • Maybe you can try repacking the extension:

    - download the zotero.xpi by right-clicking on the download link and saving from the context menu(do not install it, just download the file)
    - change the 'xpi' extension to 'zip' (simply rename the downloaded zotero.xpi file to
    - extract the zip contents to a new folder (e.g. 'zotero_extracted') with an unarchiver software
    - go *inside* this folder and select all files within; and create a new zip archive with them (e.g.
    - rename the newly created zip file to xpi (simply rename to zotero.xpi in this example)
    - install the new zotero.xpi manually with Firefox > Addons > Install addon from file.

    Restart Firefox and Voila! Hope this helps,

  • edited March 24, 2012
    The extension is fine. This is a Firefox problem due to something specific to the affected users' systems. (Even if repacking the extension worked for some reason, it'd be a fluke that was hiding the actual cause of the problem.)
Sign In or Register to comment.