Zotero library vanished locally?

Hi, my local Zotero library is now totally empty except for 1 or 2 items. If I login to Zotero online, my saved items are still there. I got a message that I'd reached my online storage limit. However, I didn't expect that my local collection would be wiped out on reaching the limit! Fair enough that it won't let me sync anything further online, but I'm rather surprised that it erased my local data. At least the data still seems to be there online, but I was trying out the sync for backup, and I really need my data locally.

Should I just reset and restore from the Zotero server? There are dire warnings about not doing so eg just for troubleshooting, so I thought I'd ask here first. Does anyone have any idea please why, on reaching my online storage limit, Zotero would erase my local library (the folder names for the sub-collections are still there, but they're empty except for 1 item)? Any suggestions on other ways to recover what I had stored locally would be most gratefully received.

Thanks in advance.
  • The storage limit has nothing to do with your item data. Whatever caused this, it wasn't the storage limit.

    Don't use the reset options until you figure out what happened. First, disable auto-sync from the Sync pane of the Zotero preferences and make a backup of your entire Zotero data directory. Next, try disabling your other Firefox extensions and restarting Firefox, and, if the items are still not appearing, provide a Report ID. Also check your database integrity in the Advanced pane of the Zotero preferences.
  • hwk
    edited January 29, 2012
    Thanks Dan. I'm glad I didn't try reset yet.

    I disabled syncing and nothing happened. Then I tried disabling just syncing of file attachments (although it's all my data that vanished, not just attachments), just to see if that might help, and not surprisingly nothing happened. However, following a reboot, the local data seems to have come back. Auto sync is still enabled, but not syncing of attachments, and I'll leave that for now just to see if it's still OK.

    Just disabling syncing of attachments should simply remove the attachments from my items stored on Zotero servers and get me some storage space back, shouldn't it? Edit - no it doesn't, I had to manually click Purge Storage while logged in to Zotero in Settings > Storage, sorry, I should have spotted that earlier.

    Thanks for your advice, if it happens again I'll shall disable autosync completely. Off to make full backup to external hard drive now! Cheers.
  • hwk - automatic syncing was not the problem here - you're just turning that off to make sure a potential error (or deleted items) in the local data isn't synced to the server.
    Generally it's recommended to leave auto syncing on to assure smoother operation.
  • hwk
    edited February 2, 2012
    Thanks adamsmith. Yes I did turn off sync immediately to make sure stuff on the server didn't get wiped too, but I turned it back on (but without attachment syncing this time) after my local items appeared following a reboot.

    I still think it's strange that my items vanished locally just when I hit my storage limit, when I've never had that problem before. Could be a coincidence perhaps. Would just be a bit nervous about paying for more storage if there's a risk of my local items vanishing when I hit the increased limit!
  • I can't tell you what happened, but it was clearly some sort of display glitch that rebooting fixed—nothing happened to your items. File syncing doesn't have anything to do with the display of your items.
  • Thanks Dan for the reassurance. I'll sign up for more storage space & retry file syncing then.
Sign In or Register to comment.