Report ID: 45119333, translator errors in American Institute of Physics

Report ID: 45119333,

translator errors in American Institute of Physics

The following error message appears when I try to get the citation via a Zotero icon.

"Could not save item"
[JavaScript Error: "No items returned from any translator"]
[JavaScript Error: "DOI Translator: could not find DOI"]

site: or
firefox ver5.0
zotero ver3.0b2
Translator is "DOI"
  • Upgrade your version of FF - FF5 is not receiving critical updates anymore.
    In general see here:
    under DOI.

    The site in general has COinS data which should work, if you provide a specific URL I can have a look why it doesn't.
  • Thanks for the comments.

    For example, the following cite:

    I can't get the citation from this site.

  • hmm - that works for me in 3.0b2, both with COinS and with DOI. Let's make sure you have an up to date copy of FF first. Also - you are using Zotero in Firefox, not the standalone, correct?

    @ajlyon - it seems odd that both DOI and COinS have priority set to 300 - we should make our mind up here, no?
  • edited December 13, 2011
    I am using Zotero3.0b2 in Firefox 5.0. Today I upgraded both. In order to upgrade FF to the latest version, I ask the administrator to do that.

    Before upgrade, I used Zotero 2.0 in FF 3.5. At that time, I have same issue, but I can get the citation from Google scholar. But now, google scholar doesn't work.

    Also I found from the following site, i can't get the citation.

    BTW, which version of FF do you recommend?

    thanks for your help.
  • edited December 13, 2011
    "Also I found from the following site, i can't get the citation."
    that site should have a dedicated translator (APS) and works for me.

    Something seems more generally wrong with your translators, you could try resetting translators from the advanced tab of the zotero preferences and then updating them from the general tab.

    Edit: You should always use a current and up to date version of FF. At this time that's FF 8.0.1
  • After I resetting the translators, I tried to update them from the general tab. But, I got an following errors.

    [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) []" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://zotero/content/xpcom/schema.js :: <TOP_LEVEL> :: line 645" data: no]"]
  • well, at least we know the problem now - if this doesn't work it's no surprise that you're getting loads of translator issues. I'll wait for Dan to suggest how to fix this.
  • Something's wrong with your Zotero installation. Could be due to the way your administrator installed it, but it's hard to say from that error.

    Restart your computer and try again. If you still have trouble, it might be a permission problem or due to some security software on your computer.
  • Restarting doesn't work.
    Do you recommend remove Zotero 3.0b2 version and install Zotero 2.1.10
  • edited December 13, 2011
    You can try it, but this isn't an issue with Zotero itself. Something is broken on your system—specifically, Zotero is unable to open files within its extension directory (your Firefox profile directory -> extensions ->
  • You can try reinstalling Zotero. Beyond that, you might need to ask your system administrator to take a look.
  • Uninstalling Zotero 3.0b2 and reinstalling Zotero 2.1.10 work !
    Thanks a lot.
  • Did you try reinstalling 3.0b2?
  • No.I didn't reinstalled 3.0b2 after uninstalling 3.0b2.
    I just installed Zotero 2.1.10. ( I was using Zotero 2.0)
  • I'm suggesting that you do.
  • No need to install Zotero 3.0b2 if Zotero 2.1.10 fixes it for you. Zotero 2.0 is outdated and no longer receives translator updates, so many things may not work with it.
  • yeah - I was curious why Dan is suggesting that, could you explain?
  • Just to see if it was the reinstall that fixed it or if there's actually something different in 3.0b2 that's triggering the problem. If the latter, wizjeong will just run into the same problem when 3.0 is released.
  • Ok. In that case, sorry for interrupting. Please do try to reinstall 3.0b2 now for testing purposes, as Dan suggests.
Sign In or Register to comment.