395148465: webDAV file synch fails

Error report ID 395148465.

This is a long-running problem for me. I posted this question some time ago: http://forums.zotero.org/discussion/15414/are-my-remote-files-infected-with-a-virus/#Item_4

Since then I have been unable to sync files. I have cleared out the remote directory and tried to do it fresh from two computers, one Windows and one Ubuntu, and I always get the same error from either computer:

Unexpected status code 503 in Zotero.Sync.Storage.WebDAV_getStorageModificationTime()

The unexpected status code changes from time to time; sometimes it's 400, sometimes it's 500, usually it's 503. Sometimes it will actually start uploading and downloading files, and sometimes it will fail right away. It never goes more than 10 seconds before failing.

I contacted support for my webDAV provider. They reset their webDAV server but said ti should be ok. They did tell me that they are seeing the following error show up:
File does not exist: /usr/local/apache/htdocs/zotero

They suggested it could be a problem with the path, but the path is set up properly in zotero as far as I can tell.

There are a number of attachment files that are missing in zotero -- when I click the attachment I get an error that says "The attached file could not be found. It may have been moved or deleted outside of Zotero." This is largely a consequence of the virus mess earlier - they are mostly html files. I am wondering if this is maybe part of problem - is it hiccuping when attempting to sync these missing files? If so I will delete them, but there are a lot and that will be time consuming. Maybe I will do it anyway while I wait for help.

Any help is appreciated. Thanks.
  • 503 is a Service Unavailable error from your WebDAV provider. Nothing we can do about it. You'll have to talk to them.

    If you provide a Debug ID we can tell you the specific request that's resulting in that error.
  • Debug ID is D70650046

    I created a new account to do a fresh sync, in case that might have been an issue. Same problem.

    I also tried this with another webDAV service. That one was working for a while but eventually failed with a similar error after about 30 minutes of uploading files. Debug ID for this service is D964730272. In this case the error was "Unexpected file upload status 409 in Zotero.Sync.Storage.WebDAV._onUploadComplete()".

    The tech at the first webDAV service reports the following:
    "Something is still wrong- looks like it's setting your username as in multiple ways, specifically:

    4244247 42474247
    (where the username at this service is 4247, and is correctly entered as such in zotero)

    Appreciate any help you can provide.
  • 409 is a "Conflict" error from your WebDAV server. This, again, is an issue on the WebDAV server's end, and you'll have to take it up with them. Searching the forums might also help—there are, in fact, other users who have gotten this error with your provider.

    For the other service, the debug output doesn't give any indication that Zotero is doing anything wrong with respect to the username, and there are plenty of successful requests.

    Zotero works with properly functioning WebDAV servers, and unfortunately we can't debug individual servers unless we have reason to think there's a bug, which is extremely rare at this point.
  • How about 500?

    I got this:

    Unexpected status code 500 in Zotero.Sync.Storage.WebDAV_getStorageModificationTime()

    when I moved to 4shared webdav service because, for the reason I didn't know, my previous webdave service (box.net) can't work anymore (I can't connect from zotero, although I can connect from browser with webdav protocol and can see the list of my data in the browser).

    For some times in the beginning 4shared worked, but now it emitted that error number.

    My file number to sync via webdav is about 800 files already.

    Previously, I have been using box.net for more than 6 months.

  • To add the info:

    The error occurs in my Firefox at lab computer a while after I pressed sync button.

    It doesn't occur in my Firefox at laptop computer. After pressing the button doesn't give any error.
  • Finally, I did the following, and it seemed the problem solved:

    I renamed the 'zotero' folder in the dav server, and created a new empty 'zotero' folder.

    From the laptop, I pushed Zotero sync button, and all the files were uploaded into the new folder in the dav server.

    From the lab computer, I created a new empty folder for Zotero, then I pushed Zotero sync button, and all the files were downloaded. But I needed to push Sync button many times until all files were finally downloaded -- each time sync-ing error occurred, I pushed the button.
Sign In or Register to comment.