"WebDAV verification failed" in standalone, but not in FF.

I'm trying zotero standalone, after having used the Firefox version for some time now. Looks great, and probably more suited to my workflow than the firefox plugin.
The major problem I encounter is that I can't get my files to sync with box.net from the standalone version. I get the error "WebDAV verification failed. Verify your file sync settings in the Sync pane of the Zotero preferences." However, the settings are the same as in Firefox, which syncs flawlessly. I reported the error under number 873356984
Anybody else having the same problem?
  • Does Verify Server work in Zotero for Firefox?
  • And, for that matter, what does it say when you do Verify Server in Standalone?
  • As a matter of fact, pressing "Verify Server" button gives the following message in both Firefox and standalone:

    "Your WebDAV server must be configured to serve files without extensions and files with .prop extensions in order to work with Zotero."

    What does this mean? In the zotero folder on box.net, I see quite a few ".prop" files. Also, the actual sync from Firefox works fine (files go to the server and reappear on the other computer I use).

    I remember that when I set up sync in Firefox in the first place maybe two years ago, "Verify server" said everything was ok. Is this some new requirement?
  • No, but you might be over a limit with your provider or something else might have changed on their end. We can't help with individual WebDAV servers, but searching the forums might turn up relevant threads on box.net.
  • Ok thanks Dan!

    There must be some difference between sync in Firefox and sync in standalone though: one reports an error and the other doesn't.

    Maybe both of them should, in which case the Firefox extension is faulty for not reporting the problem? (That is with the sync button. With "Verify server", both versions behave seemingly, but I suppose most users don't press that button very often.)
  • One has a file to upload and the other doesn't?

    Once Verify Server fails you should get the same results, but you would only see it if you were syncing files from that computer. Metadata syncing isn't affected. I'd be very surprised if you got a new file to upload from Firefox.
  • Hi Dan,

    I just tested adding an attachment in Firefox and syncing: it seems to work.

    - I could see progress bar for the upload, and there was no error reported.
    - The file in local storge is in folder XKTJT8R4. I could find both XKTJT8R4.prop and XKTJT8R4.zip on the server.
    - When I manually downloaded and opened XKTJT8R4.zip from the server, my file was inside (though with a weird lengthy name like "UGFrYXdhai5naWY=%ZB64").
    I don't have the other computer with me to see if the file would be actually downloaded by zotero as well. But for the upload part at least, it seems to work.

    Now if I close firefox and open standalone:
    - I see the attached file correctly (which is normal since standalone shares its database with firefox)
    - When I press the sync button, I get the error "WebDAV verification failed".

    This leaves me to think that there is some difference between the sync mechanisms of firefox and standalone.
    Note that although I have the latest versions available (as of yesterday), in Firefox the version is 3.0b2 and in standalone it is 3.0b2.1 Could the ".1" make the difference?
  • On a new computer of mine, I have installed the latest Zotero FF beta. I am having the same problem with box.net, and I have plenty of free storage. My other computer has Zotero FF 2.1.10. When clicking "verify box.net webdav" I get the same message about making sure I can sync extensionless and .prop files, but it works. With the latest beta, I get the error AND it doesn't sync.
  • Can you provide Debug IDs for verification attempts and sync attempts that produce the error (and for svictor, also an upload attempt that works)?
  • Hi Dan,

    The Debug ID for the computer with FF Zotero 3.0b2 is D737591305.

    The Debug ID for the other computer I have with Firefox Zotero 2.1.10 is D70290229.

    I am getting errors on both computers when I try to verify link, but I think that it might actually be syncing correctly on Zotero 2.1.10.

    Thanks for your help!
  • The 2.1.10 output shows downloading, but it shows the exact same problem uploading.

    In any case, it's a problem with your WebDAV server, not Zotero. See http://forums.zotero.org/discussion/20351/#Item_5 for details (substituting "201" for "204") and a possible workaround.
  • Hi Dan,

    Sorry for the late reply. I just made a new report from standalone ID 1439239594.

    I'm not sure what you mean when you ask me to provide "an upload attempt that works". When I upload from FF (which works fine) I get no report.

    I have 3.0 versions of Zotero in both FF and standalone. Firefox works fine, so I would rather think it as a problem with standalone?
  • I just realized that in the previous report, I had some extra errors about the Openoffice extension. I just solved them and did a new report from standalone under ID 660593435. You may prefer this one, as it should be cleaner.

  • edited November 5, 2011
    Victor: I asked for Debug IDs, not Report IDs, but see my response to swevrywhere above. It's going to be the same issue. Zotero for Firefox might be completing some of the sync even after the verification failure for some reason, but it's still not going to work properly due to the box.net bug. So either the new version I describe on the other thread will work around it or they'll have to fix it.
  • On the other thread I've posted a potential workaround, in case the problem is just that there's (now) a delay before uploaded files on box.net are made available for download.
Sign In or Register to comment.