"Run-time error 5"

Long time Zotero user and suddenly when I click Add/Edit citation in Word I get an error message that says "Visual for Basic Applications: Run-time Error 5: Invalid Procedure Call or Argument."

I am running Mac OS Monterey v. 12.6 and my Zotero software and browser plug ins are updated. I have tried reinstalling Zotero and the plug-ins. I have tried both the 2019 and 2021 versions of Word. I have updated my OS. I have restarted. The error keeps recurring.

I do not have the error on my other machine which is running Mac OS Big Sur v. 11.6.

Help!
  • Try moving all components from /Library/Audio/Plug-Ins/Components away somewhere (like temporary folder on Desktop) and see if it works then.
  • Thanks. I tried it. Didn't do anything. Still seeing exact same error.

    Any other ideas?

    Is Zotero known to have issues with the MacOS Monterey?
  • If you open the Terminal and paste
    osascript -e "display dialog \"test\""

    into it and press Enter do you get a dialog that says "test"?
  • To answer your earlier question, this is a known issue for some users on macOS.

    See the troubleshooting steps on this page https://forums.zotero.org/discussion/comment/369565/#Comment_369565

    Post here everything that you try and what happens at each step.
  • Thanks. I will do this. But I don't understand the very first instruction: "Open Zotero.dotm directly in Word." How do I do this?
  • Just double-click the file
  • Thank you. I did that.

    However, I cannot complete step 2 of disabling Macros. Probably because I am on a university-owned computer where the settings are controlled. I go to the Privacy and Security menu in word and se the setting, but I am now allowed to click on it.

    Is there something else I can try?
  • If you do not have admin rights on this machine then it's likely you won't be able to get it to work. This could be due to plugins installed on the machine interfering with the Zotero plugin or Word being locked down in some other way due to Security reasons.
  • Then that's it. I do not have admin rights. My university is very strict so they probably won't budge on this. Is there something else I can do?
  • I should add, I also tried installing a Zotero Beta version yesterday, and it didn't work. Should I try that again, or some other version of Zotero?

    Is there any expectation Zotero would develop a fix for this?
  • Sorry, this cannot be fixed by Zotero. It's a Word/macOS configuration issue, not a Zotero bug. You should talk to your IT though, since they shouldn't configure machines for academic use in such a way that breaks one of the most important academic tools.
  • Thanks. I will talk to them. They should want to help since this will not only be an issue for me but for many other professors.

    What specifically should I ask them to do? Should the ask be to revert to an earlier OS, or should it be to simply enable me to turn off Macros so that I can do the fixes prescribed in the troubleshooting links sent earlier? I'm asking because the more specific I can be about what I want them to do, the more likely I am to get some help from them.

    Thanks again.
  • edited 10 days ago
    There are extensive troubleshooting instructions in the thread I linked above (https://forums.zotero.org/discussion/comment/369565/#Comment_369565), so that's what they should follow. Reverting to an earlier version of OS is not likely to help, nor any IT is likely to do that unless there are more major issues. This will have to be resolved by figuring out what configuration is causing the Zotero plugin code (which is just standard Word macro code) to fail and changing that config.
  • Thanks. I have contacted university IT to work on the issue.
Sign In or Register to comment.