Please help... Nothing in Automation to grant permission to Zotero in Mac

edited 16 days ago
Dear all,
I just find this awesome app and I am so keen to give it a try as I am preparing a manuscript. I am using Office 365 and M1 Mac mini Monterey 12.2.1. I follow the instruction to grant permission but I do not see Microsoft word under Zotero, only Event (not really sure it is the exact wordings). I check the forum and I saw some instructions about using "tccutil reset AppleEvents" to clear the Automation. I tried and now I have nothing in Automation. But I cannot get Zotero back. I tried restarting my mac, renaming the app, using Rosetta2 to open Word, literally every method I can think of.

Some fellows suggest to use "osascript -e 'tell application "Microsoft Word" to insert text "hello" at the end of text object of active document" to see if a Hello appear and yes it does. But still I cannot get Zotero under Automation.

May I know whether there would be other ways I can solve this issue please?
  • Have been working on the solution for 3 hours and still nothing worked : (
  • edited 15 days ago
    Start by upgrading to the current version of Monterey. You're using a version from February.

    You should also make sure you're running the latest version of Word.
  • Thanks but that didnt work either
  • Just to be clear, could you explain what the exact current problem is that you're experiencing?

    Also, what exact version of Word are you running?

    And what exactly do you see in the Privacy tab?
  • Thanks dstillman.
    I would like to use the word add-in function of Zotero in Word 365. I have updated word to the latest version 16.65. I can have the Zotero ribbon but when I tried to use the function in Word I was asked to grant permission with the "Missing Permission" dialogue. I followed the instruction but I see nothing in the "Automation" tab.
  • edited 13 days ago
    I'm afraid this would point to a bug in macOS — this is totally outside of our control, and unfortunately this new macOS permissions system is still fairly buggy. The best we can suggest is to try resetting again:

    sudo tccutil reset All

    Make sure you're entering your password when prompted. (You won't see the characters in Terminal.)

    Beyond that, you can try in a new macOS user account to see if the problem still happens there.

    (And I assume you've tried deleting Zotero and Word from Applications, emptying the trash, and reinstalling them?)
Sign In or Register to comment.