import citations with html italics tags

Hello, I am trying to edit italics tags ("<..></..>" stuff), in an external editor and import them back into zotero.
Tried a few export/import formats but cannot find a format that supports italics tags (and displays properly in zotero application's screen, after import).
If I tag them in zotero app, all works fine. but there are easier tools to tag outside, like visual studio code, etc.

Any opinions ?
  • CSL JSON definitely works/roundtrips with html tags.

    BibTeX/BibLaTeX and EndnoteXML both preserve italics and other markup on import/export, but they both have their own syntax for those that's converted in both direction.
  • Yes the CSL JSON was my first target but, I am selecting an existing folder in zotero app window to export in CSL, then, without any modifications, when I try to import that JSON file back, it says, "the selected file is not in a supported format".
  • Can you try with a single item for testing?
  • edited 7 days ago
    Ok I tried some single file exports, and I think I found the problem point, it does import if the record is "journal article" or "book". Unfortunately, my list contains several "document" type also (anonymous entries, with URL, mostly pictures etc.).

    "Document" type is failing, with single entry CSL JSON export/imports tested.
  • Ah, that's obviously a bug, we should have a fix out shortly, thanks for tracking that down.
  • happy to help.
  • This is now fixed in CSL JSON
  • @adamsmith Thank you, now it works !

    Then if we can go back to main issue, I have modified the italics outside of zotero, imported back, but now I am not sure how to replace them with existing records. Will deleting older set of records (into trash) and importing this modified set, will work? (Duplicate mechanism is not working since due to italics tags, zotero dont consider these two as duplicates anymore, so they are not listed in duplicates)
  • You could sort by title and scan visually for the duplicates if it’s not too mangy items

  • Generally speaking it'd be better to avoid editing in an external editor and re-importing altogether, to be honest. If it's at all feasible in Zotero you're saving yourself a host of issues.

    But if you must, then yes, sorting by title would seem to be the way to go (note that you can still merge duplicates if you have two or more items of the same item type selected outside the Duplicates view)
  • edited 5 days ago
    @bwiernik Thanks I will try that.

    @adamsmith The truth is, I prefer to avoid editing outside too. Since I am transferring already hand-written references by help of anystyle, all formatting is gone. What I dont understand is, why there is no basic styling/formatting options (buttons or key combinations) available in zotero app, like, bold, italics,underline, super-sub script.. These are, shouldn't be very difficult to add into code, I believe.
  • Could you say what type of things you're editing? Yes, there should be editing functions in Zotero, and I think that's planned, but it also just seems like apart from the occasional italics for work titles or species names and, even more rarely, sub/superscripts for mathematical/chemical notation, you shouldn't have to do this all that much.
  • Well, I was considering possible formatting needs by other people. For me, its just the italics. But there are hundreds of, which needs to be selected and italicised individually.
  • Ok I have tested the import italicised approach.
    I have used a collection for this.

    First exported that collection to CSL JSON
    Then fixed the italics, in an external editor
    Choose my library in Zotero, imported the edited list.
    Selected all records in the initial collection folder, deleted them to trash.
    Clicked on "My library" to ensure I choose top level, and searched for some author names in the imported-list, to be sure, there are no duplicates.

    Went to MS Word, to the document containing citations in that collection above.
    Click refresh, nothing changed. All entries in the biblioghraphy are still not italicised.

    Deleted the bibliography section, and added again by "add/edit bibliography", nothing changed, still no italics.

    Tried above things after exiting Zotero and Word, and opening again. no help.

    Went to one of in-text citations, deleted a citation containing italics. Checked that its removed from references, and then added back: We have italics.

    Basically, removing non italics from Zotero collections and importing them back didn't help me to update bibliography list. May be I am missing some step ?
  • Yeah, of course not -- you created entirely new items, not linked to the Word document at all -- I hope you have a back-up of your database, because without it, the only way to now update those citations in Word is to delete and re-insert every single citation.

    If you want citations to update in a Word document, you need to use merge -- that's why we both suggested it above. If there was a solution as simple as what you did, we would have mentioned that.
  • Alright, since merge is not seeing these records as duplicates, they are not listed (due to extra italics html tags in title). I will re-do most of the stuff, since many includes italics in titles.
    I am hoping to see an update to Zotero which will allow me to do some basic styling, without need of an external solution.

    Thank you for your patience and the answers.
  • Again, you don't need the duplicates view for merging. You can just select two items and merge them.
  • Ahh, I was always considering the merge function under duplicates screen. Not aware of selecting two rows by Ctrl, and right-click menu "merge", until you indicate.

    After merging two items with proper one as 'master', refresh button works as expected and italicised versions are now being displayed in biblio. section.
    Problem seems solved.
Sign In or Register to comment.