unnecessary line break / newline in ISO-690 (Deutsch)


I am experiencing an unnecessary newline in the bibliography of the Style "ISO-690 (author-date, Deutsch)".

I am using ms word, Zotero version 6.0.13

See an example here: https://ibb.co/sg9hCws

What can I do about that? I am not seeing this issue with other citation styles. But ISO-690 is the style our group has agreed on.
  • Hi,

    I'm not able to reproduce this. The style has the entry-spacing set to the default (which is "1").

    Things to try:
    1. Change to a numeric style such as IEEE and back to ISO-690. This will rerender everything.
    2. Try in a fresh document and see if the issue persists.
    3. Check your "bibliography" Word style and see what's set there (Ctrl+Alt+Shift+S on Windows)

  • Thanks for you answer and valuable tips!

    So I have tried (1) before I have opened the thread / discussion, sorry I should have mentioned that. So this did not help.

    I have tried (2) and it actually helps. I do not see the problem anymore. Therefore the issue lies within the document. But opening a new document is not really an option in the current situation. People are working on it while it is shared via cloud storage / OneDrive.
    I also tried to completely remove the bibliography and add a new one, but the new line in the first and last line are still there.

    (3) I have set and unset some of the options. Like e.g. hanging indentation, what indents the first line as well because the (technical) first line is an empty line with only a new line character like you can see in the screenshot).

    Actually it is only wrong for the ISO-690 Style in this document. All other styles are OK. Is there somehow an option to reset the format of a style?
  • I think if you delete that "Bibliography" style and then insert a new bibliography/refresh it will recreate that word style. Try that in a copy of your document.

    Otherwise, could you not copy the contents of your document over into a new document?
  • The problem here are the various display elements used on the style. display="block" causes the extra spaces. I'd use search & replace to remove everything that's display="..." in the style (I think there's both display="block" and display="right-inline" but just looked quickly) and that should fix this.
Sign In or Register to comment.