Word restarting when trying to add a citation when text style is any other style but normal

Report ID 717572846

When I try to add a citation, and the text style on MS Word isn't defined as normal, but as quote/headline - zotero freezes while trying to add the citation, then Word shuts down or restarts (sometimes all the files shut down, sometimes they automatically open up again). Tried restarting zotero, Word, and my computer, the error persists)

Steps to reproduce (test on a new "clean" document):
1. Have your zotero open
2. Open a new word file
3. Type a few words when the text style is normal
4. Try to add a citation - should work
5. Change your sentence to a heading style or quote style
6. Add a citation -
zotero freezes, then this error comes up while Word shuts down:

Zotero experienced an error updating your document.

7. Sometimes it does work to add a citation even when the styling is quote/headline, try steps 5-6 for 2-3 times and by then it will show the error

zotero version 6.0.13
OS - Windows 11
Microsoft Word for Microsoft 365 MSO (Version 2208 Build 16.0.15601.20148) 64-bit

  • Thanks. We've had occasional reports of this from our users, but nobody had a specific reproduction case. Still, I am trying this now on my installation with Windows 10 and I can't seem to reproduce it. Could you be more specific:

    1. Does the crash occur when initially trying to show the citation dialog, or after having selected a citation?
    2. Do you have to type something in a paragraph with non-normal styling?
    3. Which citation style are you using? Does it matter?
    4. Can you create a sample document where the crash is readily reproducible (after closing and opening the file)? If so, can you upload it somewhere and link it here?
    5. Could you produce a Debug ID from Zotero for an operation that causes a crash?
  • So when I was trying to reproduce and create a file for you to check, I couldn't find a specific pattern, because sometime it did work even on a quote styled paragraph.
    What I did find is that once it happened once in a document, it starts happening much more often and on many more scenarios, even ones that were successful just moments before.

    I've collected many many debugging IDs, I hope it'll help because I'm not sure my file would. But in the file I did described my attempts and further debugging IDs

    I'll try to answer some of the questions based on this new pattern:
    1. both happens. usually the first few crashed I'll be able to choose a citation, then it'll start happening when trying to show the citation dialog (and failing, it gets stuck on the green loading line, while the Word document closes down without reopening)
    2. At first I thought it only happens in non-normal paragraph style, but then it happened in normal style as many times as non-normal (and there successful times in non-normal)
    3. when I was testing to answer your questions I've tried the headline1 and quote styles - both in their original format and after I've updated their formats. in all scenarios I've had both successes and failures
    4. this is a sample doc https://1drv.ms/w/s!Av0E7mjPtrtugs8xf7zJbiGQ4URE6g?e=Xo3PSJ - I tried to document what I'm doing so you'll see further explanations in the doc, but it's not easy to identify a pattern
    5. I've documented a few debugging IDs in the doc
  • You may want to report this to Microsoft too. Technically it's a Microsoft bug and we're unlikely to be able to successfully fix it, especially if there's no reliable way to reproduce it. Microsoft may be able to get an idea for what's causing it from crash logs and such.
  • Hi,
    Microsoft support team tried to fix it for about an hour and exhausted all the options, including suggestions from your instructions.
    His conclusion was I should remove zotero and reinstall, which I did, sadly the error persists. Here is a new debugging ID D2067614606 from just about now.

    The paragraph where it happened was in normal style, there was nothing special about it, and when I copied it to a new file it didn't happen. In the original file, after it had reopened I managed to add several citations (including to the same source) before it crashed again.

    Here is another example, this time the log should include a successful citation and a bad one D1075716735.

    If you could help me solve this, I would highly appreciate it. Sadly I think if we can't fix it I would have to replace zotero just days before a significant deadline. Thanks!
  • Ok, so I've uninstalled my Zotero, made sure to remove the zotero plugin, then reinstalled everything, then I copied my text, pasted in a new document - only as text didn't take any formatting from the old document, and it persists. it keeps crushing down.
    here is a debug ID D751616221

    Then I tried again, this debug ID will show when I'm trying to add a citation and nothing happens - not even the green bar opens, just no response:
  • Yeah, so this is a Microsoft issue, but not one that customer support can do anything about. They'll send you running around in circles with no effect. This needs to be reported to Microsoft as a bug in their software, because that's what it is. Zotero uses standard ways designed for plugins to interact with Word and any crash in Word is a the result of buggy code in Word. No amount of reinstalling or restarting Zotero is going to fix that. Zotero can work around certain bugs that have reliable ways to reproduce, but this is not one of those bugs.

    Unfortunately we don't get many users that report this, and presumably neither does Microsoft, otherwise they would have fixed it, so we don't have much to suggest. Make sure Windows and Office are up to date and save your work frequently.
Sign In or Register to comment.