The non-linkable URL link

I find that some articles's references will have URL link after being downloaded into Zotero (The color of the text will change, and if you put the pointer on it, it will display the url link such as "https://doi.org/10.1038/s41467-021-27880-7") , but those links can't open ( if you click them , it will prompt "This file has no application associated with it to perform this operation." )
So is there any way I can click the reference and jump to the browser directly to open the corresponding url link ?
Your help would be greatly appreciated.



  • Can you take some screenshots that show what you're describing, upload them somewhere (e.g., Dropbox or Google Drive), and provide a link here?
  • please share that document so Everyone with a Link can view
  • Sorry... Now it's ok.
  • Do you get the same error if you just click the "URL" label for an item's URL in the right-hand pane?
  • Actually I can't click the "URL" label in the right-hand pane. I can only copy it. I have added the screenshots into the previous Google Drive.
  • edited 17 days ago
    No, I'm talking about the "URL" label itself, not the field. You can click the URL and DOI labels to launch the associated URLs.
  • Get it. The same error does appear.
  • And another problem is I can't find the "Default Application Settings" page in the prompt box.
  • This is some sort of problem with your system configuration. All Zotero does is launch URLs via the operating system, so it should open in your default browser. You'll have to check your system settings to see why this isn't working for you.
  • Yeah, that's exactly the problem that has been bothering me. I hope it can open the browser directly and then open the corresponding link, but it can not. So I want to know where i can set it since I haven't found the correct setting page in the operation interface of Zotero.

  • Again, it's something in your system, not in Zotero itself, so you'll need to debug this. Zotero has no settings for this, and it just works on most systems.
  • OK. Thanks for your help.
Sign In or Register to comment.