Title imported as CSS class text from Amazon page on iOS

I tried to add a book ( https://www.amazon.com/dp/B09TMWHVB4/ref=nodl_?dplnkId=facadaea-ea1b-4047-b78f-6b45186362dc ) from Amazon to Zotero using the "Send To" icon on iOS Safari . But the title was imported as

.atfRedesignV2 .collapsed #expandTitleToggle { background-image: url("https://images-na.ssl-images-amazon.com/images/G/01/burj/dp_plus-sprite-2x._CB485935207_.png"); top:1.4rem; right: 0rem; } .atfRedesignV2 .expanded #expandTitleToggle{ background-image: url("https://images-na.ssl-images-amazon.com/images/G/01/burj/dp_min-sprite-2x._CB485935371_.png"); bottom: 1rem; right: 1.6rem; }

Ideally this would work properly, but if not being able to edit the title from the Zotero Send-To page would be better than nothing (and would be useful in other cases).

Notably, sending the link to Safari-Mac via Airdrop and then using the Zotero add in on the Mac worked fine.
  • When you say "Send To" icon, do you mean the Share button (square with up-pointing arrow)? I'm not being pedantic I just want to be sure that we are conversing about the same thing.

    When I use the Share / Zotero / Save to Zotero I get a Zotero book item with the title :
    Interpretable Machine Learning: A Guide For Making Black Box Models Explainable

  • Yes, that's the icon I use, and I'm still getting the messed up title on iOS Zotero (version 1.0.3 Build 5).Here's what it looked like

  • edited August 31, 2022
    I'm going beyond my level of experience here but the only difference between your and my system seems to be that you are using a dark mode. And I'm using an iPad. Might that be related to this problem?
Sign In or Register to comment.