Zotero 6.0.14 crash on opening


Suddenly, I can't seem to open Zotero without it crashing. Seems like it happens when BetterBibTex tries to update the citation keys, but since I can't get into Zotero without it crashing, I don't know how to turn off/update BetterBibTex. Any help would be highly appreciated.

I can add the report if it is needed, but it is very long.
  • You can hold down Shift at startup to trigger Safe Mode, which will disable plugins.
  • Didn't work - Better BibTex still starts when I hold down Shift
  • Send it as a mail to your support mail
  • Sorry, on a Mac it's Option for Safe Mode.
  • Thank you @dstillman. For some reason, opening in safe mode, quitting and then opening in normal mode worked.
  • Any clues on what problem BBT caused/triggered?
  • Hello @emilianoeheyns and thank you for your work on BetterBib! No actually, I have no clue. Nothing had changed that suddenly made Zotero not wanting to open. Zotero opened, betterbib started the key manager and as soon as it said "ready", Zotero crashed every time. But after opening in safe mode, and then normal mode again, it worked.
  • It happened again and this time it didn't work opening Zotero in Safe Mode and then open it again. This time I also removed some of the add-ons I had installed while in safe mode, but it still crashes every time I open it.
  • Since it doesn't crash in safe mode, i guess it must be some add-on that intervenes in some way - as I have said before, it happens after BetterBib says that key manager is ready
  • What is the error shown? When the key manager is ready the most sus things like disk/DB access are done.
  • Sorry for the late reply, weekend came up. But today when I open Zotero it works again. I will write the error message if it happens again. Thank you for the effort!
  • It happened again. What error message do you want? Is this a case for @emilianoeheyns or @dstillman ? I already did a log through the terminal that I have send to Zotero's help mail. There is also the Mac System Error Message i get everytime it happens, which is quite long.
  • I'd take the full log if you have it. You can attach it to an issue on github, I have no access to logs submitted to Zotero.
  • I have done it now, but unfortunately I can't get a Better BibTex debug ID, since I am not able to open Zotero with Add-ons.
  • Don't worry about the debug ID in this case. I don't see anything weird in those logs, BBT has finished its startup and is idle, the only error present seems to be "ObsVault Error: Error: vaultpath is not set or does not exist.", but since that exists multiple times in the logs, it's obviously not a fatal error. What is the System Error Message? You can attach that to the GH issue too.
  • I have attached it now. Will try to see what happens if I disable the add-on for ObsVault.
  • This is embarrassing, but of course that helped. I have not had any problems with that add-on before. I will contact the creator of the plugin. Thank you so much for all your help and effort!!
  • They can start by removing this line.
  • Thanks for brining this to my attention, @stefanket, and for the support emilianoeheyns and dstillman.

    @emilianoeheyns can you tell me why the `chrome://zotero/content/include.js` line in `overlay.xul` is (part of) the problem?

    I haven't yet been able to reproduce this bug, using Zotero 6.0.13 or the current 6.0.14 beta (6.0.14-beta.5+32b64b3cf) on MacOS.

    But while I'm working on replicating the behavior, there's a pre-release in the github issue without the line emilianoeheyns pointed to. https://github.com/daeh/zotero-markdb-connect/issues/29

    Thanks to everyone
  • @daeh there is a race condition in re-loading the Zotero object in include.js that would lead to crashes, plus it's superfluous since in a overlay extension, Zotero is guaranteed to exist before the overlay code is loaded.
Sign In or Register to comment.