Zotero sync issue on iphone


I am very pleased with your new IOS app, it works fine on my iPad.
However, when I installed it on my iPhone, only 80% of the papers that are on my computer zotero and iPad is synced. Could you please help?

I made a debut ID for my iPhone: D2069291972

Thank you!
  • In general, see Changes Not Syncing.

    That Debug ID also doesn't show any activity. You can trigger a sync on iOS by pulling down on the items list.
  • Unfortunately I couldnt find any of those issues.

    Ok, I tried again: D916797960
  • See what it says, though:
    If you're still having trouble, post to the Zotero Forums (in your existing thread, if you have one) with a Debug ID for the first sync after making a change that doesn't sync (e.g., making a change to the online library that doesn't appear in Zotero, or vice versa), along with a description of what's not transferring.
  • What do I do wrong then?
    I add papers daily to my library and 20% of them are missing, so I have synced and still they don't show up, hence I made a debug ID after my last sync (added several new ones the last couple of hours as well).
  • I logged out now and logged back in, lets's see if that solves it. :)
  • The point is that we can only debug what the debug output captures, not something that happened in the past. So the instructions are to generate a Debug ID of you creating or editing an item remotely and syncing in a case where data doesn't sync down.

    If you can't reproduce it, logging out and logging back in would be the easiest thing to do.
  • Now the sync was done and it worked, great!
  • It looks like this issue is still on iOS versions. I had the same issue on my iPad. Logging out and logging back was the solution. (Also, I needed to restart the app after that)
  • edited February 1, 2023
    @danielfmontero: The issue above was fixed. Please start new threads for new issues.
This discussion has been closed.