Unable to refresh or add RSS Feed

edited August 20, 2022

My Zotero(6.0.12)'s RSS Feed function stopped working two or three days ago. I can't refresh or add any RSS Feed right now. For example, it reported [JavaScript Error: "Error processing feed from http://feeds.hbr.org/harvardbusiness/: Error: Processing failed"].
I checked various RSS Feed but none of them work.

My Report ID is 611939318. Thanks for your time.

All the best
  • They’re likely just being blocked by your internet connection.
  • edited August 20, 2022
    Emm... I tried to set network.proxy.type, disable security/firewall software and use VPN, but it still did not work. I can use Doi to add papers to my library and access those RSS Feeds link with browser, so I don't understand why just RSS Feeds are blocked. Could you give me more information about which part caused this problem, Firewall software, Chrome settings, or Zotero proxy settings? I really appreciate it.
  • edited August 20, 2022
    They're likely just being blocked upstream from you.

    If you can open the feed URLs in a browser, that would tell you that it's something about Zotero's network configuration not being the same as the network configuration used by your browser, in which case Connection Error would be relevant.
  • I tried all the ways the document mentioned but still failed. So I have to use Obsidian as a transfer, though it can't show the data as clearly as Zotero did, and make the two software work together. I will keep those RSS Feeds and hope this problem will disappear one day just like how it happened.

    Thanks for your patient answer. I really appreciate it, again.

    All the best.
  • edited August 20, 2022
    Are you saying you can load the RSS feeds from Obsidian but not from Zotero? Can you load them in a browser?
  • Yep, I can always load them from Obsidian and Firefox, Chrome. And last week my Zotero was fine.
  • Does it still happen if you disable all other Zotero plugins?
  • !!!
    You are right! I'm checking which plugins cause that and tell you later!
  • edited August 20, 2022
    Pubpeer Plugin for Zotero(v 0.0.14)https://github.com/PubPeerFoundation/pubpeer_zotero_plugin causes this problem, everything is back to normal after disabled it.
    Thank you! Zotero is the G.O.A.T!
  • Are you sure about that? If you disable PubPeer, it works, and if enable it, it breaks again, and you can do that repeatedly and reliably?
  • Repeatedly & Reliably
  • I had the same issue, disabled pubpeer, and. now it's fixed! Thanks for this helpful forum thread--and hopefully it's helpful for you to know this is both reproducible problem and a reproducible fix by another user.
  • I also encountered similar problems, but I did not install the Pubpeer plug-in. I wonder if there are other plug-ins that will also affect the update of RSS?
  • @Jervine: Disable your other plugins, and if that fixes it enable them one by one until you can reproduce the problem.
  • Thanks @linghanfeiyu, that solved my issue as well!
  • @psyguy: I'm not sure what you're referring to, but this was fixed a year ago in version 0.0.16 of the PubPeer plugin.
Sign In or Register to comment.