OpenOffice 3 .doc, references not dynamic.

I'm using Firefox 3.5, OpenOffice.Org 3 with the Zotero 2.0b7.4 and the 3.0a4 integration plugin for OpenOffice.

I save all my documents in .doc format by default.

If I start a new document and add some citations, maybe a bibliography everything is great, all the Zotero produced entries are highlighted in grey, I assume meaning they're dynamic. So when I switch around a chunk of text I won't get an incorrectly abbreviated reference, it'll work out if it's the first reference of its kind for example.

However if I then save the document and open it back up my references and bibliography are no longer highlighted grey text but just plain text and they're no longer dynamic. Is there any way to get around this, it precludes me from doing my essays in more than one sitting (since saving it and closing it, kills the dynamic nature of the referencing I have to manually go back and recreate them so they're dynamic within that session).

Thanks for the help. I just wanted to know if this was normal and how to get around it.
  • If you're saving in .doc format, you need to use Bookmarks mode. To use Reference Marks (the default mode), you need to save as .odt.
  • The option to use the .doc compatible one is greyed out for me for some reason.
  • You can't use bookmarks with a note-based style due to an OO limitation.
  • Sorry, a note-based style? I'm not doing anything particularly special. I tried saving a document in .odt and then opening it back up to see if I the references were dynamic and it didn't appear to work either.

    Thanks for your help. I really love Zotero.
  • "note based" for Zotero purposes means "using footnotes" - i.e. Chicago Style, Turabian, etc.

    Can't say what's wrong with the latest step, that should work and does for thousands of open office/zotero users, so you'll first need to give us a step-by-step rundown of what you're doing there so we can potentially replicate things.
  • If you've already saved and reopened as .doc, then the reference marks would be gone. If you start from a working copy in Reference Marks mode and save as .odt or start from a working copy in Bookmarks mode and save as .doc, it should work.
Sign In or Register to comment.