No "Switch to a Different Word Processor" option in Document Preferences

This discussion was created from comments split from: RTF/ODF Scan for Zotero.
  • Hi all, I apologize if this has already been asked elsewhere but I wasn't able to find it when searching the threads. I am trying to export from LibreOffice to Word as above. I am using a footnote-based style and so need to use the transfer document option that adamsmith references above. However, when I open the Doc Preferences, I don't see the option, "Switch to a Different Word Processor" in the Zotero pop-up window. I'm using a Mac OS 12.2.1, LibreOffice 7.2.5.2, and Zotero 6.0.11. Thank you in advance!
  • (Please start new threads for new issues — the thread you posted to isn't related. I've moved this to a new thread.)

    Can you take a screenshot of what you're seeing, upload it somewhere (e.g., Dropbox or Google Drive), and provide a link here?
  • Hi and thanks for following up. I actually was able to get to the "Switch to a different word processor" after I waited longer for the reference style to update. I followed the steps that @adamsmith outlined in the other thread, which is why I posted in there. However, when I open the Word document and click, Refresh, I am prompted to update the citations but they do not update. I tried using a very short document in case it was a question of length. However, I still see the original Zotero transfer document citations as a hyperlink. Any help would be much appreciated!
  • Could you take a screenshot of the first page of the test transfer document, post it to a free image hosting site (imgur.com, Dropbox, etc.) and link to it from here?
  • edited August 16, 2022
    Hi @adamsmith and thanks for your help. I uploaded three screenshots of the test transfer document here: https://www.dropbox.com/s/bmasrc4cwzy0ris/Zotero-Troubleshooting.pdf?dl=0 Thank you!
  • Hi @adamsmith sorry to bother you again. I wanted to see if you had any ideas with the document above. Thank you in advance!
  • Sorry, was travelling & this didn't have an obvious answer. In the first (the transfer) document, can you see more of the item info in the footnote? Specifically, I'd be interested if there's actual metadata in there. That'd appear as pairs of field name and value, so "title": "Title of an article", "publication": "Publication it's published in", etc.
  • @kw47 Make sure you save the LibreOffice document as .odt before transfer and then save as .docx after restoring Zotero citations in Word.
  • Hi @adamsmith and @adomasven. Thank you both for your help as I realize you're busy. I do see metadata in the transfer document such as "title":"title of article" but it doesn't seem to update when I restore the citations.

    @adomasven, I have been saving as a .docx before using the "Switch to a different word processor" option and restoring the Zotero citations in Word as I thought I saw that was the work flow here: https://www.zotero.org/support/kb/moving_documents_between_word_processors#word_and_libreoffice for LibreOffice to Word? If not, I may be doing it wrong.
  • edited 5 days ago
    After playing with it some more, I think it may be an issue with the citation style that I'm trying to use (Chicago Manual of Style - Full Text). I'm able to restore the citations successfully if I use something like the American Medical Association citation style. I need to go through and make sure my annotations of the footnotes are all still included once I convert back to CMA but this may be a work around!
Sign In or Register to comment.