PDF reader loads large book slowly

This discussion was created from comments split from: PDF reader is realy slow on Mac M1 max.
  • I have a MAC-mini M1. I'm currently waiting for a 692 page book to build in Zotero and I'm on page 121. If I use the thumbnail view, it builds faster, but I have to wait for it to build little by little as I scroll through thumbnails. Please give us back the option to use Preview until you get your problem fixed. My wife is a grad student, using an Intel Mac and she complains also. I've been dragging the PDF to my desktop. On another note, it also has a tendency say it can't download the big pdfs, so one looks for alternate methods, which there are several, and then all of a sudden it appears.

    Thanks,

    RWB
  • edited 8 days ago
    This is a misunderstanding.

    The thread you posted to was primarily about ProMotion support for smoother scrolling on the 14" and 16" MacBook Pros. Your issue doesn't have anything to do with Apple Silicon Macs, which in all cases run Zotero considerably faster than Intel Macs — you're just trying to open a very large PDF. I've moved this to a new thread.
    Please give us back the option to use Preview until you get your problem fixed.
    This has always been configurable from the General pane of the Zotero preferences.

    There's no general problem with performance in the built-in PDF reader for most PDFs, but if you're frequently opening 700-page PDFs, using Preview might be a good idea for now.

    Zotero 7, coming next year, will improve the PDF reader's performance.
  • General Preferences is the first place I looked. The only option I saw was Config Editor and when I checked that out there was a warning that using this would void the warranty . . . . okay then I have to reload the program if I mess it up got-it. Nevertheless I didn't see the option under that button either. Cpuld you please explain.
  • edited 8 days ago
    You're looking in the General tab of the Advanced pane of the preferences, not the General pane. It's literally on the first screen of the preferences. It's not an advanced setting.

    https://www.zotero.org/support/preferences/general
  • Thanks got-it, change made. I'll be looking forward to the update, I liked the features of the Zotero editor and they did work well for short documents.
Sign In or Register to comment.