Files stored in My Library links lost after reinstall

I had to reinstall Windows 11, and therefore Zotero. I set my data directory to be within documents, so it's: \Users\[username]\Documents\Zotero

All the document information I've added to Zotero is visible, including tags, collections, etc. However, Zotero can't find the PDFs linked to the references. I get an error that states: "The attached file could not be found at the following path:" the path is
\Users\[username]\Documents\Zotero\storage\[alphanumeric name]\articlename.pdf

However, when I look in the Zotero folder:
1) the storage folder is empty
2) the PDFs are available, but they're stored in a folder called "My Library" and each PDF is within a simple numeric folder, e.g. \Users\[username]\Documents\Zotero\My Library\files\[single or double digit number]\articlename.pdf

When I search the forums, Zotero seems to store PDFs in the storage folder with complex alphanumeric names. How did I end up with the My Library/files/ structure? More importantly, can I re-link these files to the appropriate reference?
  • edited 16 days ago
    No links were lost here. The files just aren't present in your Zotero data directory.
    2) the PDFs are available, but they're stored in a folder called "My Library" and each PDF is within a simple numeric folder
    That's just a Zotero export you made. That's not a backup and not something you would want to use to transfer data to a new computer.

    You don't say how you transferred your Zotero data to this installation. If you used Zotero syncing to pull down the library, it's just that you didn't set up file syncing before wiping your computer, because you have almost no synced files online.

    Did you make a backup of your computer before reinstalling Windows? You should absolutely always have a full backup of your computer before wiping it. If so, you can simply copy your Zotero data directory from the backup.
Sign In or Register to comment.