iOS app crashing repeatedly, not syncing with Zotero library

Hi,

I'm having issues with the iOS app. I tried deleting it and reinstalling, but it hasn't fixed the problem. I can view my whole library on the app, but if I edit the reference on iOS the change doesn't show up in my library on my computer. If I try making a change, and waiting for it to sync, generally the iOS app crashes within five minutes. If I make a change in the client, the changes show up eventually in iOS, but usually not until it's crashed and been restarted.

Here's the debug ID that popped up in iOS when I restarted the app after a crash: Report ID 2141297346. I believe that was after making a small change to the iOS version of a reference, as well as a small change in the client version (different fields, as a test). When I restarted the iOS app, the client changes had taken effect there. The change I'd tried to make in iOS reference had not saved in iOS or in the client.

I do use ZotFile to store this library's files in an alternate location, but linked files shouldn't impact my ability to work with the references themselves on the app, right? I've tried this with a library that is stored on Zotero.org (with no use of ZotFile), and it seems to work seamlessly, but that's a much smaller library. Not sure if that could have any impact.

Thanks!
Sign In or Register to comment.