Safari Zotero connector can’t save ScienceAdvances articles

See e.g., https://www.science.org/doi/10.1126/sciadv.abm4665

The Zotero connector on safari doesn’t recognizes this as an article, but adding the DOI through the "add item by identifier" button in Zotero works.
  • Could you please provide a Connector debug log?
  • (Start logging, reload the page that isn't being recognized, stop logging and submit.)
  • Sure!

    The Debug ID is D1206223074.
  • It looks like you're loading the page from within an AddThis frame. If you have an AddThis browser extension enabled, try disabling it. If you're opening the page from within the AddThis site somehow, could you try loading it directly?
  • I don’t have any extension named AddThis. And all other websites work fine with the connector.
  • Translators: Looking for translators for https://s7.addthis.com/static […]

    The Debug ID you provided is for loading an addthis.com URL.
  • edited 22 days ago
    @alexcr87: It looks like science.org integrates AddThis, but that just means your Debug ID wasn't for a full reload of the page. There should be much more output. Can you try again?
  • What I’m doing:
    - open the Science page,
    - open the Zotero connector pref pane,
    - enable logging,
    - reload the Science page,
    - wait for the page to stop loading,
    - disable logging,
    - send log.

    The first time I did this it logged 14 lines. Just did it again, now waiting 1 minute after loading completed, it logged 14 lines again at first, but 16 more lines after the page finished loading. It seems to log additional lines every time I switch back and forth between the Science page tab and the pref pane tab though, this is weird.

    In any case, it still doesn’t recognize the page as an article. The [new] Debug ID is D120718992.
  • Not sure what to tell you, but it's just not a full load. Try it in a new tab rather than reloading.
  • Just did it again with a new tab + waiting 1 minute after full page load.

    The Debug ID is D2144007268.
  • edited 21 days ago
    Could you try holding the shift key while you click the reload button in the address bar? That triggers a full reload from the ScienceAdvances site. Make sure debug logging is started first.

    Sorry for the inconvenience and thanks for helping us figure this out.
  • The Debug ID is D1843942639
  • edited 20 days ago
    (3)(+84200377): Translators: Looking for translators for https://s7.addthis.com/static/sh.f48a1a04fe8dbf021b4cda1d.html#rand=0.44[…]

    (4)(+0000428): Translate: Binding sandbox to https://s7.addthis.com/static/sh.f48a1a04fe8dbf021b4cda1d.html#rand=0.44[…]
    Sorry, but there's just something very strange going on in your Safari installation. This just isn't a real page load, or at least none of the logging that would appear for a full reload of the page is appearing here. It's only showing a single third-party frame being reloaded — and, here, it shows almost a full day of no other activity before this reload.

    Have you tried just restarting Safari or your computer?

    In general, on this site in Safari, it takes about 5 seconds for the page to finish processing and for the save button to turn into the journal article icon. After that, it works.

    While this page is working for us (once the page fully loads), note that the Zotero Connector for Safari is much more limited than the ones for other browsers, and the Safari extension framework is much buggier.
  • I had a bunch of extensions installed in Safari and after testing them one by one, the AdGuard extension was causing this. There’s 8 extensions installed by AdGuard and it’s the "AdGuard General" one that’s causing problems. Also, after disabling/enabling the extension the changes don’t apply unless I clear the website data in Safari. And it can take anywhere from 5-20 seconds for the Zotero Connector button to turn into an article.

    Found out that telling Safari not to use content blockers for science.org (Websites tab in the Preferences, then in Content Blockers) seems to work, even with all the AdGuard extensions enabled.
Sign In or Register to comment.