LibreOffice on Ubuntu doesn't recognize Java

This discussion was created from comments split from: Issue with Libre Office Plugin on Ubuntu 22.04.
  • I have the same problem. I tried 3 other JDK, but LibreOffice doesn't recognize them und says, there was no JAVA installed. It is a Problem of LibreOffice, but LO Support is not responsible for the Plugin is inofficial. Has anyone solved the problem yet or found a workaround?
  • @Lorenzobianco: That doesn't sound like the same issue. What OS and what exact versions of LO and the JDK have you tried?
  • I use Ubuntu 22.04 LTS, LibreOffice and the command "java -version" generates:
    openjdk version "18-ea" 2022-03-22
    OpenJDK Runtime Environment (build 18-ea+36-Ubuntu-1)
    OpenJDK 64-Bit Server VM (build 18-ea+36-Ubuntu-1, mixed mode, sharing)
  • That should work. Are you saying the JDK doesn't show up at all in the Advanced section of the LO preferences? Because that would obviously be an LO issue, unrelated to the Zotero extension, and something they would have to help with. You don't even need to mention Zotero, since you're not even trying to install the extension — you're just trying to enable Java in the LO preferences.
Sign In or Register to comment.