Zotero will not open Mac OS Monterey

Zotero 6.0.9 will not open on my Mac. Everything has been running since Zotero 6 came out in March, but suddenly when I click to open the app it just bounces in the dock, and then stops without ever opening the app. I deleted and reinstalled the app from the Zotero downloads page, restarted my computer, and updated to the latest Mac OS (Monterey 12.4), but when I run the debug text in Terminal I get the following error message:

% /Applications/Zotero.app/Contents/MacOS/zotero -ZoteroDebugText
2022-07-13 21:29:02.670 zotero[3755:46095] Minimum OS version requirement not met!

Thank you so much for any tips to get Zotero back up and running!
  • edited 29 days ago
    Hmm, that's extremely strange, and I think would have to be due to something you've installed or changed on your computer. No one else has reported this, and it shouldn't be possible with the current version of Zotero on Monterey.

    Can you confirm this is with 12.4? Not any macOS beta? Are you running any third-party software that might be interfering?

    Do you recall anything you did to your computer since this last was working?

    What Mac is this?
  • I can't recall anything I've done on my computer since this was last working - I've been using Zotero almost every day and then one day last week it just stopped opening.

    I confirmed I am running Monterey 12.4. This is on a 13-inch MacBook Pro from 2020 (2.3 GHz Quad-Core Intel Core i7, 32 GB memory).

    The only third party software I can think of that could be interfering is the Notero plug-in I use to sync Zotero with a Notion database (https://github.com/dvanoni/notero) -- but this has been working beautifully for the last few months. I am not sure how to uninstall it to test whether that is the issue since I can't open Zotero, and I added it via the Zotero Add-ons Manager.

    Thank you for any ideas of what to try!
  • Yeah, Zotero plugins shouldn't make a difference here.

    Do I understand correctly that this started happened before you upgraded macOS? So it wasn't updating that caused it?

    If you delete Zotero from Applications and install the Zotero beta instead, does that have the same problem? (There shouldn't be any difference, but just as a thing to try.)
  • Correct - this started before upgrading macOS. I updated to see if it would fix the issue.

    I deleted Zotero from Applications and tried installing Zotero beta instead, but same thing happened.

    When I delete and reinstall, the first time I try opening the newly installed app it bounces for a few seconds in the dock and then just disappears. When I try opening it from Applications any time after this first attempt, it doesn't even appear in the dock, it just bounces for a quick second as if opening and then nothing happens.
  • OK, we can fix this, but it just really shouldn't be happening. Basically, there is indeed a macOS-version-detection bug in the underlying framework we use, but it shouldn't be triggered in Zotero, and doesn't seem to be happening to anyone else. But if you give us a day or so, we'll try to put out a new beta that should fix this for you, regardless of what on your system is causing it to happen.
  • Thank you so much for being willing to help me solve this! I have no clue what triggered it. Really grateful for your help - my whole research workflow revolves around Zotero and all the improvements in 6.0 have been so great! Thank you again for your help.
  • edited 26 days ago
    @zarapito, @utmital: OK, unfortunately we have no way of testing this ourselves, so this might take a little back-and-forth, but can you install the latest test build (link removed — see below) and see if Zotero starts?

    If it does, please:

    1) Provide a Report ID

    2) Take a screenshot showing the tabs in the right-hand pane after selecting an item, upload it somewhere (e.g., Dropbox or Google Drive), and provide a link here, or email it to support@zotero.org with a link to this thread

    3) Let us know if anything else seems broken in the build
  • @dstillman that worked!!

    1) Report ID: 1581718737
    2) I emailed a screenshot showing the tabs in the right-hand pane to support@zotero.org
    3) As far as I can tell everything seems to be working well in the test build - just looks like I may need to reinstall/reconfigure a plugin

    Please let me know if I can test anything else in this build -- otherwise I'll stay tuned for when there's a version that's ready to use. Thank you so much for helping with this issue!
  • OK, thanks — that's exactly what I needed.

    So if you switch to the latest Zotero beta, it should fix the startup failure and the styling on those tabs (which is a side effect of this strange behavior you're seeing).

    @zarapito, @utmital, @alessandro.tel, please test that out and let us know if you notice anything else amiss. Barring any problems, we'll release 6.0.10 within the next few days with this fix.

    (I'm also still curious if anyone experiencing this knows what might have triggered it, since it really shouldn't be possible. It seems a bit curious that the three people who have reported this have all known enough to try to start Zotero via Terminal, though maybe that's just from finding our instructions. If you're seeing this, do you use Homebrew, Xcode, or similar tools? Do you make advanced system-level configuration changes or use unusual system utilities?)
  • Thanks @dstillman -- the latest Zotero beta is working beautifully so far. I will report back if any other issues pop up.

    I do not use Homebrew or Xcode, and only knew to try to start Zotero via Terminal by following your instructions on how to report startup errors. I definitely don't know enough to make advanced system-level configuration changes! I still have no clue what triggered this issue on my machine - the problem seemed to begin pretty randomly.

    Thank you again for your swift help on this - I am super grateful to have Zotero back up and running!
  • Hello @dstillman

    The beta version worked for me too!

    1) Report ID: 1833505423
    2) I have emailed the requested screenshot to support@zotero.org

    Things seem fine so far. I'll get back if anything seems broken.

    I also started Zotero from terminal following your instructions on how to report startup errors. Regarding any tools, I use conda to create some custom environments on my macbook. But I do not recall doing anything different that could have triggered this issue. I use Zotero on an almost daily basis. Much like @zarapito, the problem seemed to have begun out of the blue.
  • OK, this fix is included in Zotero 6.0.10, available now, so if you don't want to stay on the beta, you can install that from the download page.
This discussion has been closed.