LibreOffice plugin installation error: MalformedVersionException

This discussion was created from comments split from: Error plugin installation LibreOffice.
  • I also could not install the Zotero LibreOffice plugin on the Mac today--running Big Sur OS 11.6.6, with Zotero 6.0.8.

    I tried to install it manually and also got errors.

    Bug report: 96530395
  • I tried pretty much everything in the installation error page except upgrading the LO installation, which is v. 7.2.7 (most recent stable version). I can upgrade to 7.3, but it has a tendency to crash unexpectedly. LO reports that it is using JDK 18.x, which I had to install when I first tried to install the Zotero plugin. I installed everything for an Intel Mac (or at least thought I did).

    Here is some additional info. When I try to install manually, I get this notice:

    You are about to install version 5.0.23 of the extension 'Zotero LibreOffice
    Integration'.
    That version is already installed.
    Click 'OK' to replace the installed extension.
    Click 'Cancel' to stop the installation.

    When I go ahead and click OK, I get this error from the LO extension manager:

    (com.sun.star.uno.RuntimeException) { { Message = "C++ code threw
    N10jfw_plugin25MalformedVersionExceptionE: std:: exception", Context
    (com.sun.star.uno.XInterface) @0 }}

    Here is the error that is generated by the Zotero error reporter:

    DavaScript Error:
    "TypeError: temp is null" (file: "chrome: / / zotero/content/bindings/preferences-mac.xml"line:1225}]
    getPreferenceElement@chrome://zotero/content/bindings/preferences-mac.xml:1225:11
    userChangedValue@chrome:/zotero/content/bindings/preferences-mac.xml:1273:25
    onxblcommand@chrome://zotero/content/bindings/preferences-mac.xml:1312:0
    JavaScript Error: "uncaught exception: unopkg at /Applications/LibreOffice.app/Contents/MacOS/unopkg failed to install"]
    JavaScript Error: "TypeError: temp is null" (file: "chrome: / / zotero/content/bindings/preferences-mac.xm/"line:1225]
    getPreferenceElement@chrome://zotero/content/bindings/preferences-mac.xml:1225:11
    userChangedValue@chrome:/zotero/content/bindings/preferences-mac.xml:1273:25
    onxblcommand@chrome:/zotero/content/bindings/preterences-mac.xml:1312:9
    JavaScript
    Error: "uncaught exception: unopkg at /Applications/LibreOffice.app/Contents/MacOS/unopkg failed to install"]
    version =
    6.0.8, platform => Maclntel, oscpu => Intel Mac OS X 10.16, locale => en-US, appName => Zotero, appVersion => 6.0.8. extensions => Zotero LibreOffice
    Integration (6.0.0.SA.6.0.8, extension), Zotero Word for Mac Integration (6.0.2.SA.6.0.8, extension)

  • edited 17 days ago
    MalformedVersionException
    That's the relevant error for you. This is just an LO bug, covered on the troubleshooting page:
    On macOS, LibreOffice 6.4 and 7.1+ work with all JDK versions up to JDK 17.0.2. LO 7.3.5 fixes compatibility with JDK versions above 17.0.2.
    You're trying to use JDK 18 with LO 7.2.7.
  • I went through all the steps and still had the same problems until I downgraded to JDK 16.

    JDK 17 will work with LO, but not with Zotero and LO. Need to roll back to JDK 16
  • edited 16 days ago
    We tested with 17.0.2 a few days ago, but it may vary by the exact build you download. It’s due to a + in the version string. In any case, it should be fixed with 7.3.5.

    Nothing to do with Zotero. It’s just an LO bug. You’d just only see it when trying to use a Java-based extension.
  • I just downloaded and installed the available version from Oracle (17.0.2 build???), and it didn't work. So it may be more reliable to just go with JRE 16. As I said, I normally like the advanced tech versions of LO (currently 7.3) but it has been crashing a lot, so it may be better for most people to stick with the latest 7.2 for a while.

    Something that would help in the very useful trouble shooting page would be instructions on how to install any version of Java that is earlier than the current Oracle version that is packaged with an installer, and how to set it in LO. Here are some draft instructions if you'd like to add them.

    To set your version to LibreOffice to work with a specific version of a Java Runtime Environment (JRE) on the Mac, do the following (requires admin privileges):

    1. Download the desired version of JRE from https://jdk.java.net/archive/ and uncompress it to a folder.

    2. On your Mac, open the the folder:

    /Library/Java/JavaVirtualMachines

    You can do this by selecting the Finder "Go to Folder" option from the "Go" menu and pasting/typing /Library/Java/JavaVirtualMachines into the text box.

    3. Drag your uncompressed JRE folder into the /Library/Java/JavaVirtualMachines folder (You will need to supply an admin password to do this).

    4. Start LibreOffice and open Preferences.

    5. In Preferences, select LibreOffice/Advanced. Then select the version of JRE you want to use.

    6. Close Preferences and close LibreOffice

    7. Install the LibreOffice/OpenOffice plugin from Zotero.
  • This is actually fixed in LO 7.3.4, available now. Thanks for the write-up, but LO 7.2 is already end-of-life, and people should just switch to 7.3 for this fix.
  • I'll try 7.3.4 and see if it is stable now. The write up should be good for any version where someone needs to install the proper JRE to work with Zotero.
  • Right, but the point is that that shouldn't be necessary. Current versions of LO work with all versions of the JDK.
  • OK. That is good.
Sign In or Register to comment.