paste citations broken in google docs

This error comes up for the last week or so. This is working in chrome on chromebook. It appears to go through all the steps and a broken link is the result.

500: Google Docs request failed.
"error": {
"code": 500,
"message": "Internal error encountered.",
"status": "INTERNAL"

  • Let me amend slightly: I just did a paste, got the error, but the citations were intact. Previous times they were not.
  • Can you provide a Debug ID from the Zotero Connector for this happening?
  • Debug ID is D430745611
  • This time it the citations became unlinked when pasted
  • edited June 21, 2022
    If you go to the Advanced pane of the Zotero Connector preferences, is "Enable Google Docs Integration v2 (NEW)" enabled? Try toggling it and seeing if that makes a difference.
  • So the only thing to toggle was "Enable Google Docs Integration". I unchecked it and still got the error. Strangely, it does not always break the pasted citation.

  • When I rebooted gdocs, though, as I obviously suspected, zotero wasn't available. not sure what other switch to toggle
  • No, don't turn off "Enable Google Docs Integration". What version of the Zotero Connector do you have? You should have 5.0.96, and then you should have a "Enable Google Docs Integration v2 (NEW)" checkbox.
  • OK, the last time I looked at it, I think the V2 version was greyed. I am running the 5.0.96. When I checked the V2 box, and rebooted my gdoc,
    I still got the same error message. Worse, I get an error when I just try to add a citation now. (Cntrl-Alt-C)
    The error dialog just states "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?
    Here is the current debug ID
    The Debug ID is D723895254.
  • OK, we'll look into that and the original pasting issue. For now, you can turn v2 back off.
  • Note - same error problem using chrome on windows 10 machine
  • edited June 26, 2022
    I don't know if this further confuses, or adds some useful clues:
    Always, in the past, (in the v1 of gdocs integration) pasting a citation was accompanied by a short delay and a 'please wait' before the paste was complete.

    Now, with v2 toggled off, I got an array of different results.
    Pasting a large block of text with many single and multiple citation blocks went through without the 'please wait' or the "500 error" I thought for sure the citations would be broken, but apparently they weren't.
    In other pastes, it appeared that single citations broke but multiples didn't, even with the "500 error".
    Then I tested various different combos, like 2 singles in a block, 2 multiples in a block, and various others, and despite the "500 error", none were broken.

    In another variation, I tried pasting and got the "500 error, (without the "please wait") but NOTHING pasted. Immediately trying cntrl-V again, the paste happened followed by a "0 google docs request failed" error, but the citations worked just fine.
    The Debug ID after trying this (and other things) was D1142360415.

    In sum, the paste, despite the error messages and variations, appears to be working at least 90% of the time.
  • @aarwdc Can you reproduce this error consistently by copying some specific citation in this document? Can your submit a Debug ID from Zotero (instead of the Connector)?
  • The 500 error comes after every paste. Sometimes it breaks the pasted citation, sometimes not.
    When you ask for Debug ID from Zotero, I assume you want the information from Tools>Developer>Error Console.
    Producing the error does not add anything to the Console, and the "Errors" tab is blank.

    Here some of the messages listed under "All". I have omitted some that appeared duplicative:

    1656429941130 addons.update-checker WARN Update manifest for did not contain an updates property

    [JavaScript Error: "You have reached your Zotero File Storage quota. Some files were not uploaded. Other Zotero data will continue to sync to the server.
    See your account settings for additional storage options.
    02699931.2016.html (821 KB)"]

    [JavaScript Error: "Upload request 1/2FFYJ8ZV failed"]

    [JavaScript Error: "WebSocket connection closed: 1006 "]

    [JavaScript Error: "The connection to wss:// has terminated unexpectedly. Some data may have been transferred."]

    [JavaScript Error: "WebSocket connection closed: 1006 "]

    [JavaScript Error: "The connection to wss:// has terminated unexpectedly. Some data may have been transferred."]

    [JavaScript Error: "Upload request 1/2FFYJ8ZV failed"]

    [JavaScript Error: "Upload request 1/2CW7HH7V failed"]

    [JavaScript Warning: "Error in parsing value for ‘height’. Declaration dropped." {file: "chrome://zotero/content/standalone/standalone.xul" line: 0}]

    [JavaScript Warning: "Key event not available on some keyboard layouts: key=“i” modifiers=“accel shift alt” id=“key_importFromClipboard”" {file: "chrome://zotero/content/standalone/standalone.xul" line: 0}]

    [JavaScript Warning: "unreachable code after return statement" {file: "resource://zotero/loader.jsm -> resource://zotero/bluebird/util.js" line: 205 column: 4 source: " eval(obj);

    [JavaScript Error: "NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsICommandLine.handleFlagWithParam]" {file: "file:///usr/lib/zotero/components/zotero-service.js" line: 551}]

  • No, we want a Debug ID. You provided one from the Zotero Connector, not from Zotero.
  • @aarwdc If you create a new document and insert some Zotero citations into it, then try to copy them into your existing doc, do you also get the 500 error? Can you cut down the size of the document to a small snippet, make sure it still produces the 500 error, then send it to
  • Ok, I looked at the document you sent us and that appears to be a Google Docs bug, which I reported to them. Notably, it seems to be caused by some interesting indentation at the very end of the document. If I select all the empty paragraphs at the end of the document and delete them, the issue disappears for me, so it's likely you will be able to fix it yourself by doing that too. More generally you can follow the step 11 of Troubleshooting Errors in Word Processor Documents to remedy the issue, by finding the problematic parts in the document (there may be multiple) and removing them.
Sign In or Register to comment.