Mendeley Import completes with 0 items imported

Hi there,

I am looking to shift from Mendeley to Zotero. I have about 4,400 entries linked to about 9.5gb of PDFs.

I am using the Zotero as follows to import.

File > Import... > Mendeley Reference Manager (online import) > (Next) > Sign in via your institution* > (My University selected) > (My university login screen) > Place imported files in a new folder > Importing... > Import Complete (0 items were imported) > (Finish)

*I cannot sign in using my email because each time it will require me to authorize via an email to sign into the account.

I am wondering if this is linked to the fact I am logging in via my institution, rather than my email (which is a personal, non-institutional email address, but the account IS linked to the institution -- if I log in online using the institution, I would be on the same account, for example). Any help appreciated.
  • Institutional logins should work — which is why it's trying to import at all. But if it's getting 0 items, that really just means it's not finding any data.

    To confirm, if you do that login process outside of Zotero, do you actually see your Mendeley data?
  • I just migrated yesterday from Mendeley to Zotero (Mendeley got a complete Sh*tshow since I last used it with Word...).

    My situation might have been similar to yours, I have a Mendeley account dating back to 2009, paid for extra storage privately until 2018 when my university decided to maintain an institutional login. I haven't changed my login settings, still using my private email address for login (but having the 100 GB file limit etc. of the institutional account) and used it for the migration as well and although it took a while I got all of my 6-something GB library transferred.

    Can you disable the 2-factor authentication for your own email address temporarily or do the email authorization once for migrating your data in one session?

    I hope this helps you at least figuring out some starting points to troubleshoot.
  • edited 12 days ago
    Hi, I managed to get it working. I'll let you know what I discovered in case it is useful for future troubleshooting.

    Before Elsevier moved to a 'one-login-everywhere' system, I had my personal email account linked to Mendeley, and my Scopus/Elsevier account linked to my university email address. At some point during the shift to a 'one-login-everywhere' system, my institution got linked to my personal Mendeley account. So, based on this situation, I would be able to go to the Mendeley website and login directly through my personal email address, or select 'Login via institution', which would take me to my institutions' interface to log in using my institutional email and password. Whichever way I logged in, I would be on the same Mendeley account -- the one linked to my personal email.

    When trying to import Mendeley library into Zotero, ideally I would have just logged in via my personal email address. Of course, that doesn't work because Elsevier requires me to validate via email on an external browser (as noted in my initial post above). But I was able to log in via my institutional account -- which, via Mendeley's website, would still take me to my Mendeley account linked to my personal email. As mentioned, when trying this, the import would 'complete' with nothing imported.

    So I tried something else: I logged into Mendeley using my institutional email and a password linked to Scopus/Elsevier kept from before it became a 'one-login-everywhere' system. Note that this is different to 'Login via institution'. I am using my institutional email to log in, but not via my institutions' interface. Once logged into Mendeley, it was a completely different account -- linked to my institutional email, and with nothing in my library. This is obviously what Zotero was picking up when coming to import.

    The way I resolved it likely isn't available to everyone... My aforementioned institutional account was from somewhere I left 5 years ago (but still maintain ties as an honorary member). I've since joined a new institution. So, I linked my new institution -- which at present is not linked to any of Elsevier's systems because I've erstwhile maintained my old institution's access -- to my Mendeley account linked to my personal email.

    When trying to import into Zotero using the NEW institution, it worked and imported all 9gig/4400 entries. Unlike the old institution, it would not have been confused by an institutional email linked to another Elsevier service prior to their 'one-login-everywhere' system.

    TLDR: It's an issue at Elsevier's end and the carnage of having a 'one-login-for-everywhere' where, prior to that, some accounts were based on an institutional email, and others were based on a personal email -- and then 'wrapping it all' with an institutional link. I hope this makes sense?

Sign In or Register to comment.