Limiting Number of Authors

Hello Zotero Team,

I would like to add a rule that "et al" gets added after the third author if there are six or more authors. (If there are 1 to 5 authors all of them should be listed.) I can't figure out where to place this in XML coding. I was trying to use this forum post ( as a reference but it's still unclear to me where this rule should be inserted.

Thank you,
  • In the bibliography, yes?
    Find the line that starts with <bibliography and add
    et-al-min="6" et-al-use-first="3"
    If there are existing values for either of those two, just change the number.
  • Hi Adam,

    Thank you for your quick response and for your help with this! I was able to find line and make the adjustment.
  • Hi Adam,

    I made the change you suggested but now "et al" does not appear at all, regardless of the number of authors. Additionally, Zotero is only listing 1, 2, or 3 authors. It stops at 3 even if there are more than 3 authors, and again, no "et al". I undid this change in XML and that didn't solve it. Any ideas?
  • most likely you defined the et al. term away in the terms section -- typically right below the info section. For everything more, I'd have to see the full style (put on or so & link to here)
  • With the style you posted, I get
    1 Fenner M, Crosas M, Grethe JS, et al. A data citation roadmap for scholarly data repositories. Scientific Data 2019;6(1):28. doi:10.1038/s41597-019-0031-8
  • This is what I get:
    1 Meriney SD, Tarr TB, Ojala KS. Lambert-Eaton myasthenic syndrome: mouse passive-transfer model illuminates disease pathology and facilitates testing therapeutic leads. Ann N Y Acad Sci 2018;1412(1):73-81. doi:10.1111/nyas.13512
  • You've checked the item in Zotero? And how are you testing the style exactly?
  • In the Zotero desktop app, I click on Edit>Preferences>Cite>Style, then select my style (the one I sent you yesterday). From there, I click on Style Editor and find that "et al" is not listed (the example I just sent you). Is there another way to check and/or add it in?
  • Copy the code straight into the style editor. If that produces different output, you're likely installing a different/older version of the style.
  • I tried copying it into the style editor and received this message: "Error parsing style:
    Error: File is not valid XML"
  • And that happens when you go to, click the "Copy" button at the top, then remove the current style from the style editor (select all --> delete) and paste?
    If so, please double check that and also let us know which version of Zotero. Definitely not happening for me.
  • Yes, I click "copy" at the top, delete the current style from the style editor, and paste. I'm using the 6.0.8 version.
Sign In or Register to comment.