Zotero not working with MacOS 13 Ventura beta

edited June 7, 2022
Hi. I'm unable to load Zotero on MacOS when using the Vectura beta. I'm using the Zotero beta version already. Thanks.
  • edited June 22, 2022
    It worked fine when I tested it yesterday. What’s the problem, exactly?

    [Update, June 22: We've identified the problem in the Ventura beta. For now, use the release version of Zotero, which should work fine on the Ventura.]
  • When I attempt to open it, the Zotero app jumps once (as if it's loading) with the circle below showing it's open. This lasts for less than a second and then the circle disappears (app hasn't opened).
  • Have you tried restarting?

    Is this an Apple Silicon Mac?

    Can you check whether there’s a crash log in Console.app and provide the first 100 or so lines if so?
  • edited June 22, 2022
    Yep, tried restarting. M1 Macbook Pro 13inch.

    Report is from last night when the installation was completed

    -------------------------------------
    Translated Report (Full Report Below)
    -------------------------------------

    Process: zotero [3791]
    Path: /Applications/Zotero.app/Contents/MacOS/zotero
    Identifier: org.zotero.zotero-beta
    Version: 6.0.9 (6.0.9)
    Code Type: X86-64 (Translated)
    Parent Process: launchd [1]
    User ID: 502

    Date/Time: 2022-06-06 22:03:44.0320 +0100
    OS Version: macOS 13.0 (22A5266r)
    Report Version: 12
    Anonymous UUID: 2E69B2DC-4FB2-8388-23C5-E1BB01155A1A

    Sleep/Wake UUID: 2E81AA8D-4322-4C8D-9C9A-A241117B3485

    Time Awake Since Boot: 920 seconds

    System Integrity Protection: enabled

    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000198
    Exception Codes: 0x0000000000000001, 0x0000000000000198

    Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
    Terminating Process: exc handler [3791]

    VM Region Info: 0x198 is not in any region. Bytes before following region: 140723024002664
    REGION TYPE START - END [ VSIZE] PRT/MAX SHRMOD REGION DETAIL
    UNUSED SPACE AT START
    --->
    mapped file 7ffca1db8000-7ffca7f70000 [ 97.7M] r-x/r-x SM=COW ...t_id=2957a4f9

    Kernel Triage:
    VM - pmap_enter retried due to resource shortage
    VM - pmap_enter retried due to resource shortage
    VM - pmap_enter retried due to resource shortage
    VM - pmap_enter retried due to resource shortage
    VM - pmap_enter retried due to resource shortage


    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 XUL 0x115b687e4 0x113b10000 + 33916900
    1 XUL 0x115b1fb50 0x113b10000 + 33618768

    Thread 1:: com.apple.rosetta.exceptionserver
    0 runtime 0x7ff7ffd56a90 0x7ff7ffd52000 + 19088
    1 runtime 0x7ff7ffd6edd8 0x7ff7ffd52000 + 118232
    2 runtime 0x7ff7ffd62168 0x7ff7ffd52000 + 65896
    3 runtime 0x7ff7ffd62be4 0x7ff7ffd52000 + 68580
    4 runtime 0x7ff7ffd641e8 0x7ff7ffd52000 + 74216

  • There may be a problem when running under Rosetta — we've only tested on Intel so far. But this would be a Ventura bug, since Zotero works on Intel and works under Rosetta on Monterey.

    Try deleting the app from Applications and reinstalling. If that doesn't work, you'll need to wait for the next Ventura beta to see if this is fixed.
  • Ok cool, thanks. Appreciate installing beta has its risks. FYI: I have tried deleting and reinstalling with no luck. Let's see what happens for the next update.
  • I am having a similar problem, also using an M1 Macbook Pro.
  • Thought I'd like to update you. I just downloaded the 6.08 version from the download page -IT WORKS!!
  • Previously I was using the Zotero Beta 6.09 version
  • edited June 22, 2022
    @hnugraha: If you reinstall the beta, does it stop working again?

    There was another report of this, but there really shouldn't be any difference between the release version and the beta version. It's much more likely that this was some sort of caching bug in macOS/Rosetta.
  • @dstillman

    I just installed macOS 13 Ventura Beta 2 and Zotero 6.0.9 Beta 5 still doesn't work on it, while Zotero 6.0.8 does.
  • OK, thanks. I can confirm this — and on an Intel Mac, so it's unrelated to Rosetta.

    It seems that if our internal macOS app identifier (CFBundleIdentifier) is set to anything other than org.zotero.zotero, the app crashes at startup. That includes our beta builds, which use org.zotero.zotero-beta. I can reproduce this in a local development build just by altering CFBundleIdentifier, with no other changes.

    Meanwhile, a newer version of Zotero that we're working on, built against a newer macOS SDK, works on Ventura regardless of the value of CFBundleIdentifier.

    The only explanation that I can think of is that Ventura has some sort of hard-coded compatibility shim in place for org.zotero.zotero, and current versions of the app won't start without it. There's no difference between builds that work and builds that don't other than the value of CFBundleIdentifier.

    I've reported this to Apple (FB10419695), so hopefully they'll fix this for the next beta. For now, the release version of Zotero should work fine.
  • Apple appears to have fixed compatibility with the Zotero Beta in Ventura Developer Beta 6, and it will hopefully be fixed in the next Ventura public beta as well.
Sign In or Register to comment.