How to export item & pdf from Zotero to Endnote

I am a new Zotero user but experienced Endnote user and want the flexibility to move between the two, at least for some time.

I have searched the Zotero support forum and documentation for 'export pdf endnote' but can only find advice for how to import FROM Endnote TO Zotero (e.g. and However I need help the other way: export TO Endnote FROM Zotero WITH pdfs. Curiously I have been unable to find resolution.

I've managed to find advice for how to export using the Zotero RDF option (including files and notes) but Endnote does not want to import the pdf(s) along with the item(s).

My current Endnote X1 library is ca 1500 most with pdf attachments. I am considering importing them into Zotero but I want the option of exporting them out again for my colleagues who still use Endnote.
  • well once you're in Zotero, why would you go back to endnote ;-)
    Seriously, though, export/import both ways isn't really good enough to "go back and forth".
    From Zotero you would probably want to use the RIS export - that does include links to files, though possibly you need to fix them - you would have to look at the RIS output if this doesn't work automatically. Endnote reads RIS without problems, though.
    Maybe you would need to tinker with Endnotes import filter, too.
    This won't be entirely lossless, it's just not there yet (and Endnote, of course, has no interest in it ever being...)
  • Thanks for the reply. Any suggestions for how to 'fix' and 'tinker' the RIS output? I am still at a loss.
  • my apologies - I remembered that incorrectly - Zotero does indeed not export the link to attached pdfs in any of the standard export formats (RIS, BibTeX, MODS/XML). I don't have a good idea of what to do - this really should be addressed, being able to export in a clean way is an important feature of citation management software...
  • edited November 8, 2009
    I can not agree more and very surprised that the issue has not surfaced before now. Can someone enlightening us?
  • Indeed, I have tried Zotero before and did not like it. I want to give it a second chance now, but definitely want the ability to go back to endnot or another programme. Could this be implemented?
  • Is EndNote able to import PDFs from any of the standard formats? If so, what method do they use to denote a link to a file (L1 ?)
    Zotero does indeed not export the link to attached pdfs in any of the standard export formats (RIS, BibTeX, MODS/XML)
    Note that EndNote cannot import MODS or BibTeX directly. But the Zotero translators could in principle output attachments for each of these formats, just as they already import attachments from them.
  • Zotero is free software, why someone donĀ“t made this possible?, i mean, endnote isn't compatible with RTF of Zotero (obviously they aren't so good like us ;) ), but Zotero should have the option to export references (for example with RIS format) to end note (is freeeeeeeee, software, i never would change zotero for endnote, but is for another people) this way the accesibility and flexibility of Zotero could be maximun...thanks, bye...long live to Zotero...(and 2 for the creators of it)
  • Zotero has RIS export - this thread is just about pdfs.
  • edited April 19, 2010
    yes, i know that (RIS, MODS, BibsTeX)... sorry i don't was specific...i was talking about pdfs attachments...because is very important when we are dealing with many documents and many references. I talked about RDF (not RTF ;) ) because Zotero give us the option to export the references with the pdfs in this way, but endnote doesn't accept RDF format.
  • edited April 19, 2010
    Please someone with knowledge of the open code, should exist someway to do that...something like an alternative format with the option to export to endnote with my precious pdfs, thanks.

    If all my partners use endnote and i can't exchange or share all my work with them, i think i have to use one just a example...
  • I think it's basically a matter of writing an extra RIS export translator that will add the absolute file url (i.e. file:///path/to/your/file.pdf ) in the L1 - field for the RIS record.

    Then in Endnote on the same computer you can convert file attachments to relative links (via References / File Attachments menu item). Then the endnote file and data directory is transportable across computers with associated pdfs.

    Bringing them back into zotero means that you ahve to work out the file paths for the internal-pdf pseudo-urls, and convert them into absolute paths before importing the RIS into zotero.

    To be honest I don't think RIS export of links to pdfs would be terribly difficult for the zotero developers to add (via a checkbox like export files in the RDF format), and it would reduce the irritation of having to collaborate with Endnote users a bit (poor souls).
  • edited April 21, 2010
    Yes, same here. I need to export the PDFs to a supervisor of mine: he is especially interested in the full-text PDFs I collected. However, in their institution they can only use Endnote or they have to manage PDFs manually. Is there some way to export my PDFs only or export into Endnote? Thank you in advance.

    Btw, I recommended Zotero to him. Hopefully he can convert the rest of the institution ;)
  • that's currently not possible at all, unfortunately - I'd hope developers would add this soon - seems very little work and there is essentially a consensus on what to do - i.e what kieren says above.
  • you do not need to "export pdfs only". you can create a search for.pdf inside the zotero folder, and there you have all the pdfs. Then you can copy all of them, or then ones you need from your search results. If you give them meaningful names or you have used the "rename from parent" feature you can order and select them either according names or date added.
  • Is there any news of whether or not this issue is being worked on? I have come to 'love' Zotero and do not plan to go back to Endnote, but I still have about 1500 references with attached PDFs waiting to import into Zotero from Endnote.

    I could of course do what 'migugg' suggests above and manually import the PDFs and then create new reference items for each PDF. But this would take considerable time, especially since I already spent much time in Endnote editing the item details and abstracts (they often download from the net (metadata) with missing or incorrect information).

    My point is not whether or not there exists feasible 'workarounds' but that these are impractical and time consuming. Fixing a filter that automatically interprets the location of the PDF and links it to the appropriate reference item would save much valuable time.
  • there is ongoing and quite ambitious work by someone outside of the core dev team to improved Endnote import, including pdfs -
    I'm not sure if that will include import of files from Zotero back to Endnote - although I still think that should be addressed - but importing files from Endnote to Zotero (what you seem to be asking for now) seems to work relatively smoothly.

    And please don't triple post - if you bump one thread that's absolutely enough to get people's attention.
  • Thank you for such a prompt reply!!

    I will try that and report back here.

    Oh, and PS, I only noted this issue twice today (the other as a 'feature request' and the third was a different issue). I simply assumed that different developers monitor different 'boards' but I'll not repeat. ;)
  • edited January 22, 2011
    I tried exporting from Endnote to Zotero with the new fix, however I received several errors. I am running windows xp with firefox 3.6.13 and zotero 2.0.9 as well as Endnote X1. This what I did:

    I replaced the zotero RIS.js file with the fixed RIS.js ( and saved the original as RISold.js, both in the zotero 'translators' folder.

    Next I exported the entire Endnote bibliography using refman RIS export style.

    I was unable to open the RIS file to edit in Endnote (as described here:

    Instead I ran the ris-fix.vbs tool as explained here ( to change the LI path in the RIS file (exported endnote library) to the actual pdf folder in Endnote.


    Only 500 out 1300 references imported.

    Many had strange notes attached.

    None of the PDFs imported correctly. Instead I get the error message: "The attached file could not be found. It may have been moved or deleted outside of Zotero.'

    Any advice?

    Thank you!

  • I was unable to open the RIS file to edit in Endnote (as described here:
    What do you mean you were 'unable to'?
    Instead I ran the ris-fix.vbs tool as explained here ( to change the LI path in the RIS file (exported endnote library) to the actual pdf folder in Endnote.
    Open the resulting file & copy/paste one of the L1 links into your browser. If it can't resolve, than Zotero won't be able to find it either. If you can't figure out what is wrong with the link, post it here.
    Only 500 out 1300 references imported.
    Try to find where this problem is. Are all 1300 in the RIS file created by the ris-fix.vbs?
    Many had strange notes attached.
    Please explain this further.
  • edited January 22, 2011
    I went back tried a different process but without success. I did the following:

    I found where to edit the style in Endnote X1: Edit>Output Styles>Open Style Manager>Bibliography>Templates which opens the RIS fields (e.g. L1).

    Like the fix help instructs I checked that all L1 fields are changed to L1 - `File Attachments|` in the RIS style for Export

    Then in the txt output file (which I renamed with a *.ris extension) I did the following find/replace

    L1 - internal-pdf://
    L1 - <path_to_folder_where_EndNote_library_lives>/<EndNote_library_name>.Data/PDF/

    However, since Zotero was not reading the *.ris (txt) file on import

    I also replace "internal-pdf://" in the exported endnote *.ris (txt) file with "file\\" so for example L1 can read

    L1 - file\\C:\PeteronC\Literature\EndnoteBackup\EndnoteCopy.Data\PDF-The acceptabil-1261011968/-The acceptability of assistive technology to older people.pdf

    This time I didn't run the ris-fix.vbs tool on the generated Endnote ris file.

    Then I edited the RIS.js file, adding the <path_to_folder_where_EndNote_library_lives> to the line: var RIS_internalPDFPath =

    Then I ran Zotero import.

    I let Firefox/Zotero 'import items' for about 3 hours and then accidentally closed Firefox. However when I started it again nothing had imported.
  • edited January 22, 2011
    still having difficulties

    tried fiddling with the *.ris LI field (with and without 'file:///' or 'internal-pdf:').

    Most current attempt is without:
    L1 - C:/<path_to_folder_where_EndNote_library_lives>

    The path is correct. I checked and was able to open the pdf by pasting it into an explorer path window, however none imported into zotero.

    I let Firefox/Zotero run for about 5 minutes and then closed it and reopened - no imports. Importing begins with error message 'could not save item'

    using with modified 'RIS_internalPDFPath.'-to match Endnote's pdf folder as instructed (see L1 above).

    Here is the Debug ID: D1362099219.
  • Errors and debug output are both cleared on a Firefox restart, so there's nothing of value in that report.
  • edited January 22, 2011
    okay, what do you suggest? I could let it run overnight if you think it would finish and reveal something

    another point: the instructions here read:

    - To correctly import File Attachments, you must edit RIS.js and place the
    absolute path to your EndNote PDF folder:
    in the variable "RIS_internalPDFPath."

    however I can not find 'RIS_internalPDFPath' in the original 'translator' (RIS.js) included with Zotero so I have replaced it with this - along with the correct <path_to_folder_where_EndNote_library_lives>

    Is one option to insert the variable "RIS_internalPDFPath" into the original Zotero RIS.js translator?

    (getting desperate here)
  • I haven't worked with this significantly, so I really can't say how Jonathan's code works. The original Zotero RIS translator doesn't let you specify the path, as far as I know. Support on the weekends is a little but slower-- but this _should_ work. We'll make it happen.

    Another general troubleshooting step here is to split your RIS file into pieces and try to import smaller pieces-- sometimes malformed entries can stop the whole import, or perhaps there is an entry (even a correct one) that is exposing a bug in the import system. So break the file up and try smaller pieces.
  • edited January 23, 2011
    Hello! I think I'm almost there. Zotero successfully imported about 1000 references with PDFs but then stopped. I've tried to submit the debug report but the Zortero server must of timed out (returned error). The debug report had about 750000 lines. The report wouldn't open for viewing. I took the advice to split the export in half with about 650 references each but still a bug and still the server returned an (large 750000 line) error. I will try now splitting in quarters (ca 300) see what happens and report back.
  • edited January 23, 2011
    Well, this time all 376 references imported, but the debug log was about 550000 lines and apparently too big, once again, to submit. It appears that none of the attachments were named properly, including the PDF files. However it did work to open the attachments which means, I assume, that the real PDF paths are being read correctly from the Endnote pdf folder, just that their title names and types are being lost. (For instance Zotero only displays a blank 'note' or 'attachment' icon instead of the yellow post-it note or red & white PDF icons in the reference.)

    To get a sense of what is going on I imported 10 references to generate a debug report ID. The Debug ID is D1713612250 .

    Here are the adjustments I've made for the last few imports:

    1. I made a complete new backup copy of my Endnote library from within Endnote, and closed the application.

    2. I downloaded the most recent style file 'RefMan (RIS) Export.ens' (2010) and copied (replaced) it in the Endnote 'styles' folder.

    3. I reopened the new (backup copy) Endnote library and I edited the L1 line for the 'RefMan (RIS) Export' style in Endnote's style manager as Jonathan instructs here: (FYI - all reference type L1 lines were changed with the edit of L1 for 'journal articles'.)

    4. I stopped renaming the extension of the output file from *.txt to *.ris. Jonathan's RIS.js seems not to mind the .txt extension. (I don't remember why I thought I should change the extension... perhaps linked with the attempt to use the ris-fix.vbs tool which I have stopped using.)

    5. I pasted Jonathan's RIS.js file into Zotero's 'translators' folder, and updated the pdf path as he instructs here:

    6. I opened Zotero and (sadly) deleted all the recently imported references, selecting by 'date added' and ready to try importing again with your advice. :)
  • So you're set now? It sounds like things are working now.
  • edited January 23, 2011
    Unfortunately, NO!

    I am making headway but there are still many bugs being generated. It looks like there are many unknown tags that are creating problems. Also, with the 376 imported items Zotero stopped. (I don't remember exactly what the error message read and couldn't send the debug report.) That's why I imported only 10 to create the debug ID that I was hoping someone could look at. Any ideas?
  • Sorry -- only core devs have access to submitted debug data. Hopefully one of them will be able to take a look and say what's happening.
  • edited January 24, 2011
    To follow up with all of this, I am wondering if someone might suggest a way to reduce the number of unknown tags generated during import? My guess this that this could help reduce the thousand plus lines of errors in the debug reports.

    Perhaps taking a look at the Debug ID is D1713612250 could offer some clues (created while importing only 10 references).

    Also, is there a suggested max number of imported references that Zotero can handle at once, each with at least one note and a PDF attachment?
Sign In or Register to comment.