Not possible to add citations when working in a online version (One drive/sharepoint)

I've been struggling with Zotero now for a couple of weeks with different word documents. There is often this issue, that if I add a citation in a document saved
in OneDrive/SharePoint, an error appears, leading me to the bug-fixing website, where I already tried all steps. However it works perfectly if the document is my desktop.
Once I am working in a shared document, I would like to keep working online and with no need to download and reupload every time I need to add a citation. My whole team is able to do so. Why I can't. does anybody know how to fix it?
  • You don’t need to download/reupload. You can open a document in Word Desktop from the online interface or sync to your computer using the OneDrive/Sharepoint/Teams Sync button
  • I know that it is possible. but an error message appears when I do.
    "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?"
    And I have already tried what it is said in the instructions. any suggestion to correct this error?
    Thank you in advance
  • Can you provide a Report ID, as requested on Troubleshooting Errors in Word Processor Documents?

    But note in particular the step about spaces in the filename when using OneDrive.
  • I had the same problem: zotero show the same message of error when trying to import a citation in word.
    First I opened a new document, it worked,
    I copy pasted my content to a new doc, it worked for the first ref then got the same message again for the second one.
    I moved the file from onedrive to the hard drive. It solved my problem so far.
  • I can't figure out how to install Zotero on SharePoint. Is there a way to work with Zotero while using a shared document on SharePoint?
  • Did anyone ever get an answer for this issue? I am facing the same problem with my work team and will much appreciate any input.
  • @lmsbarnes: The answer is above. It's a known issue that can occur for documents with spaces in the filename stored on OneDrive. We've never been able to reproduce it ourselves, but renaming the file to avoid spaces usually fixes it for people.
  • Just here to add that removing spaces did, in fact, solved this issue for me.
Sign In or Register to comment.