Zotero menu in Google Docs not working

Hi all,
In google docs, when I click on the Zotero menu, either nothing comes down, or there's a tiny little space that drops down, but no menu like there ought to be. Ctrl-Alt-C doesn't bring up the dialog to insert a citation.

Things I've tried:
- reinstalling connector
- disabling *all* other extensions in chrome
- restarting computer
- restarting zotero
- disabling and enabling google docs in connector options
- closing *all* other tabs in chrome

Any help greatly appreciated. At the end of my rope here. It feels like the connector isn't able to connect to Zotero somehow (does it connect to the desktop app? online?). Could windows firewall be causing issues?


Win 10 Education
Zotero v 6.0.8
Chrome Version 101.0.4951.67 (Official Build) (64-bit)
Connector v
  • Ok, so, if I turn on "allow in incognito mode" in the chrome extension config, the menu starts working again. I am not in incognito mode (and would prefer that zotero not work in incognito mode). Any thoughts on what might be going on here?

  • I have the same issue, with the same version of zotero, but even in incognito mode Zotero doesn't work on Google Doc.
  • @ashenkin, @soizicbrun: Can you provide a Debug ID for loading Google Docs and not getting a working menu, with all other browser extensions disabled?
  • Finally it is now working with the incognito mode (only in this mode). I think that then I had to relaunch Google Chrome so that the Zotero menu would appear in Google Doc.
    The only issue I still have is that when I add a citation from Google Doc, there is a pop-up message from Zotero saying that I need to wait until the document is being updated. This message remains until I take action: I have to go to the desktop Zotero and open the window entitled "quick format citation" to add the citation and then the pop-up window disappear and I can keep working on my Google Doc. It took me some time to understand that.
  • You shouldn't need to use incognito mode, so we'd still want the debugging info I ask for above.
    I have to go to the desktop Zotero and open the window entitled "quick format citation"
    Generally the citation window should appear on top of your other windows automatically. If you have to go find it each time, that's not right — you should restart your browser and Zotero and try again, and if it still happens you should see if you have any sort of third-party utility or system configuration that might be interfering with how windows normally appear.
  • Hello @dstillman !

    The debugging number is 1610001171, but it doesn't seem to have registered any issue. I disabled all Chrome extensions and it seems that the issue was due to the Google Docs offline's extension. I don't know if I prefer to work on incognito mode or disable this extension. Anyway, I have two options to make it work.

    Also, for the second issue, I have already restarted my browser plenty of times. Sometimes there is a popup windows in top of my google doc, sometime I have to open Zotero. It's no issue for me.

    Thanks a lot for your support.
Sign In or Register to comment.