Zotero quits unexpectedly when saving from Chrome

Hi, I'm having some technical issues when saving references from Chrome. When I hit the "Save to Zotero" button, Zotero quits unexpectedly. I've already tried reinstalling Zotero and the Chrome add-on, but it didn't work.
  • Try disabling any third-party Zotero plugins.
  • @dstillman Hi, thank you for the reply! I tried but it didn't work. Also, when I enabled the add-on, it continued to crash when I save references from online.
  • Can you 1) provide a Report ID from Zotero with all plugins disabled and 2) provide any sort of crash log from your OS? (If it's long you can include just the first 100 or so lines, or email to support@zotero.org with a link to this thread.)
  • edited May 20, 2022
    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 CoreFoundation 0x7ff80ceea311 __CFStringEqual + 243
    1 CoreFoundation 0x7ff80cf5c0a3 CFCachedStringEqual + 41
    2 CoreFoundation 0x7ff80cf59848 _CFXNotificationRegistrarFindName + 89
    3 CoreFoundation 0x7ff80cf596b4 CFXNotificationRegistrarFind + 642
    4 CoreFoundation 0x7ff80ce12c37 _CFXNotificationPost + 622
    5 AppKit 0x7ff80f8a97eb -[NSView _postFrameChangeNotification] + 304
    6 AppKit 0x7ff80f8a288b -[NSView setFrameSize:] + 2304
    7 AppKit 0x7ff80f8b33d5 -[NSView setFrame:] + 404
    8 AppKit 0x7ff80f8c5185 -[NSView resizeWithOldSuperviewSize:] + 691
    9 AppKit 0x7ff80f8c4b04 -[NSView resizeSubviewsWithOldSize:] + 488
    10 AppKit 0x7ff80f8a2602 -[NSView setFrameSize:] + 1655
    11 AppKit 0x7ff80f8b33d5 -[NSView setFrame:] + 404
    12 AppKit 0x7ff80f8c5185 -[NSView resizeWithOldSuperviewSize:] + 691
    13 AppKit 0x7ff80f8c4b04 -[NSView resizeSubviewsWithOldSize:] + 488
    14 AppKit 0x7ff80f8a2602 -[NSView setFrameSize:] + 1655
    15 AppKit 0x7ff80f8c25a3 -[NSWindow _oldPlaceWindow:fromServer:] + 867
    16 AppKit 0x7ff80f8c097e -[NSWindow _setFrameCommon:display:fromServer:] + 1278
    17 XUL 0x11b8b0107 0x119853000 + 33935623
    @shengpeng_c: We got the crash report — thanks. Can you provide the Report ID with all plugins disabled? And please do try again that way. We've mostly only seen this 1) when people are using multiple monitors and 2) when using a third-party plugin that causes a progress window to pop up in Zotero during saving.

    In any case, this will be fixed in a future version of Zotero after we upgrade the underlying framework.
Sign In or Register to comment.