zotfile deletes annotations when get from tablet is applied on win10 desktop


I have now run several times, if not frequently in the similar, nightmarish issue that when I use motile to get my pdf from the table, it deletes my annotation that I made during the reading.

I found a hint in the following thread, but it did not really help me to understand where this problem is grounded in.


Usually I create the entry for zotero and add the.pdf and then rename the attachment, so all files have the order of year_author_title in their name.

I'd really like to avoid this in the future, I already create copies of my.pdfs before I get them via Zotero, but I'd prefer to avoid that step and trust zotero. However, i am kind of aware that one of the main causes for errors usually sits in front of the notebook. So I'd be really happy if someone can help me to enlighten this case

Another question on top of that is, if I add a pdf that includes already annotations can I extract them only by right click and clicking "add note from annotation". I thought that there was also a way to extract them and also rename the file to name_annotated.

with kind regards,


  • The linked thread was about ZotFile's rename-and-move feature, which while Zotero 6 was in beta would delete annotations created in Zotero's new PDF reader. That was fixed before Zotero 6 was released.

    It's possible this still happens with ZotFile's separate Get from Tablet feature, but it's not clear what exactly you're saying is happening. Can you provide exact steps to reproduce the problem you're experiencing?

  • I tried to reproduce the problem, but I am not sure if this help. It's not like zotero even tells me that there is a problem or crashes.

    It just that the files that it receives via get file from the tablet happens to have lost all the annotations.

    It seems to happen especially within one of my subfolders for my current research and when I try to get files from there, it does delete the annotations.

    I had sent the attachment via zotfile to my google drive, made the annotations on my android tablet with acrobat reader, and then use zotfile to get the file back to zotero to extract the annotations automatically, but none annotations are extracted and if I open the pdf in zotero or any other pdf reader, all annotations seem gone.

    What is extremely strange, that with the file I tried it now, that if I sent it back to the tablet, the annotations appeared again. However, when I tried it a second time, the annotations were gone. And when I now try to reproduce it, by making annotations on the tablet and then get the file back. It keeps happening that the annotations are gone.

    My hunch is that it's a problem within acrobat reader and the google drive that the file is not correctly saved or saved at all, because when I close the pdf on the tablet in acrobat and reopen it again the annotations are there. However, if I open it from my desktop on the google drive. They seem not to exist. But I don't know why.

    What I don't understand why this happened to files that I haved worked on different days. I guess I have to wok around this problem for now.
  • edited May 13, 2022
    You'll need to be more specific about where you're creating the annotations.

    Annotations you make in external readers should be saved to the file itself, and that doesn't have anything to do with Zotero. You can open those files outside of Zotero to see what's in them.

    Annotations you make in the built-in PDF reader in Zotero 6 are saved to the Zotero database. If you send those to a tablet, you won't see the annotations in the exported file. If you use Get from Tablet, it might wipe out the ones in the database, though I'm not sure about that.
  • I am making the annotations in acrobat reader on my android tablet as I wrote.

    I am kind of aware that zotero is just one probable station of this error. However, it keeps happening when I am using the get from tablet function and it's also zotfile that then deletes the file from my google drive, or? Is there a way to neglect that. So zotfile keeps the file on the tablet?
  • I can't help you with ZotFile, but you can check the file in Google Drive on your computer before you run Get from Tablet to see whether the annotations are present. If not, they just weren't saved properly on the tablet or weren't synced properly.
  • I have this problem too. The annotations are visible in the Tablet folder but not when the item is opened in Zotero (whether before or after Get from Tablet is applied). If I apply Get from Tablet and then Send to Tablet the annotations are gone, even from the item in the Tablet folder.
  • same issue. Before pressing "Get from Tablet" I checked on PC with a separate pdf viewer (mupdf) that annotations exist. After pressing "Get from Tablet" annotations made on tablet are gone.

    Weirdly if I do annotations directly on PC in that file and overwrite the file before pressing "Get from Tablet", then annotations from PC appear back in zotero and get extracted.

    And the last:
    1. "Send to tablet" -> Make annotations > verify with external pdf viewer on PC -> Add additional annotation on PC -> both annotations exist -> "Get from tablet" -> (no notes extracted) -> open pdf in zotero's pdf reader-> No annotations from tablet, but the ones made on PC exist.

    What worked for me is to press "Update MOdification time" under "Modify attachements" before I pressed "Get from Tablet". This option is not available if you right-click an item on zotero subcollections. Only if you right-clicked in Search folders "Tablet Files"/"Tablet Files (modified)" created by Zotfile.

    Then tablet annotations did not disappear although were not extracted automatically. I had to extract them by hand. For whatever reason If I annotate file that was "Sent to Tablet" on PC and then pull him back everything works (even automatic note extraction).

    1) Tablet pdf reader: Foxit reader/Acrobat reader
    2) PC pdf reader: mupdf
    3) OS: arch linux
    4) For syncing a folder on PC and tablet I use "syncthing".

    Hope that helps.

Sign In or Register to comment.