Google Docs - library not loading

Hi!

I just created my Zotero account today (synced it, verified email), and I added a source to the library to test out a citation in Google Docs. When I click the "Zotero" button next to "Add-ons" nothing shows up (although the button is highlighted). I'm wondering if I missed a step in the set up?
  • edited 13 days ago
    Do you mean the Zotero menu next to Extensions? (At least in my Google Docs, Add-ons is an option in the Extensions menu, which the Zotero menu appears to the right of.)

    Try restarting your browser, and if that doesn't help try disabling all other browser extensions. Be sure to reload Google Docs afterward.

    If it still doesn't work, can you take a screenshot, upload it somewhere (e.g., Dropbox or Google Drive), and provide a link here, and also provide a Debug ID from the Zotero Connector for reloading Google Docs and clicking the Zotero menu?
  • Thank you for the quick response!

    I tried restarting Chrome (and updated it - "add-ons" was an outdated term) and disabling all other extensions, then reloading Docs but it didn't seem to work.

    https://docs.google.com/document/d/1iZLqs1aSdBYpPVDgpsRRVTFPgt7ILzWZNMwD_Ygsz7M/edit?usp=sharing

    Here's a doc with the screenshot of what I see when I click. I couldn't right click the Zotero Extension on docs to generate a Debug ID - again, please let me know if this is something I'm doing wrong on my part! Thank you for your patience
  • Sorry just managed to access options - I'll try to get an ID now!!
  • Here's the debug ID: D2035076349
  • Can you try the Debug ID again? It needs to show you actually reloading the page, not just switching to the tab.
  • Sorry about that. This time I switched tabs, reloaded, tried clicking the zotero menu, then switched tabs to submit the output.
  • ID: D1324744937
  • edited 13 days ago
    Can you open the Chrome developer tools (View → Developer → Developer Tools) on a Google Docs page, switch to the Console tab, copy the contents, paste them somewhere, and post a link here?
  • edited 12 days ago
    And that's with all other extensions disabled?

    If so, best we can suggest is to try in a new Chrome profile, which has fixed this for other people. (If that works, it might be possible to figure out what's causing this in the old profile.)
  • Using another Chrome profile works! I used my school email profile.
    I'm using Docs with my school email but on my personal Chrome profile - is there an issue there? Either way, I'm glad it works this way! Thank you for your help and patience, it truly means a lot.
  • @adomasven might have some ideas about things you could check in the settings to get this working in the old profile.
Sign In or Register to comment.