Moved Zotero to new computer, Multiple Profiles don’t appear

Hello, I changed computers and copied my Zotero directories to the same locations on the new computer.

I had 3 profiles and my Zotero folders are not in the default locations. When I open the profile selector, there does not appear to be a way to import the existing profiles.

I also get errors trying to connect to my old zotero.sqlite file; I’m not sure if that may be a related or separate issue. Unfortunately, I am not able to use the online repair tool and I have no online sync.

Any help would be appreciated. Thank you!
  • The profile directory and the data directory are separate. To transfer profiles, you'd have to transfer the Profiles folder containing the profile directories.
  • edited May 4, 2022
    (But you can also of course just create new profiles, point them at the existing data directories, and delete any empty data directories creating in your home directory.)
  • Tried the first suggestion (copy profiles) and that did not work . The new folders were not recognized and I think that dialog pulls from an ini but I’m not sure where that ini might reside. I copied it into the Profiles folder but that did not have any effect on the options either. So… second suggestion it is — create new.
  • edited May 4, 2022
    You need to copy both Profiles and the profiles.ini file in the same folder. It's just the same structure as on the first computer. You wouldn't copy the .ini file into Profiles.

    There'll already be a Profiles and profiles.ini on the new computer if you've run Zotero once, so you'd just be replacing those files.
  • Update: Found and updated the profiles.ini file in the \AppData\Roaming\Zotero\Zotero and voila, profiles restored and databases open without error except for 1 database.

    Is there a workaround for “Database upgrade error”?
    The backup gives the same error.

    Database malformed; [QUERY: DELETE FROM fieldsCombined WHERE fieldID NOT IN (SELECT fieldID FROM itemData)]
    From previous event:
  • edited May 4, 2022
    It looks like that database is corrupted. Try copying it again, and make sure Zotero is closed. You can also try the DB Repair Tool, but if you're not getting that error on the original computer then it seems like something happened during the copying.
  • I am not able to use the Repair Tool (company policy prohibits file uploads to external website) and unfortunately I no longer have access to the old computer so I am limited in my current options.
Sign In or Register to comment.