Zotero Citations get lost when copy-pasting to a specific ODT-document


I use Zotero (I would prefer not to update right now) and LibreOffice : and experience the following problem: when I try to copy text from an ODT-file to another ODT-file including zotero citations, the citations get lost (they become simple text, the link is gone). The strange thing is that this only happens when I copy the text into a specific document. When I create another ODT-file and try copying the text/citations there, it works fine. What do I do?

  • Are citations stored as ReferenceMarks?

    See: When using LibreOffice, if you are storing citations as ReferenceMarks (the default), you must save your document as .odt. If storing citations as Bookmarks, you must save your document as .docx.
  • Yes, the citations are stored as ReferenceMarks in all my documents. The document, from which I want to copy the citations, was previously edited by a proofreader, who also used LibreOffice, but possibly a newer version.
  • That seems quite odd -- you're positive they're no longer active citations? E.g. editing citations doesn't work nor does adding a bibliography? Don't just go by field shading.

    Does the taget document use some sort of template? That might interfere with copying reference marks.
  • Yes, I am 100 per cent positive - the citations are no longer active.

    It must have something to do with the document, since copying them into another, new document works...
  • p.s. I use different styles (default style, footnote) etc. for different parts of the texts, but (as far as I am aware of) no template.
  • Does the source document matter? If you paste from a different LO document with Zotero citations into that new document, do those citations stay active?
  • Ok, so I tried two things:

    I copied citations from another random LO document into the document I am working on (where the copied citations from the proofread document would not show/ get lost) and it worked, i.e. they were preserved.

    Also, I copied citations from a random LO document into the proofread document, and it worked as well.

    So, my conclusion is that there must be an issue with the source document, i.e. the LO document, that I got back from my proofreader. Do you have any idea, what that issue might be, since the citations in the document itself look normal?
  • Hard to say and it's a LibreOffice bug, so they may be interested in your broken document to be able to fix it. Either way, does copying citations out of the affected document work? If so, the simplest workaround for this issue is likely going to be to just copy the contents of the broken document out into a fresh working one.
  • Thank you, but that did not work.
  • edited April 19, 2022
    Do you think an update of LO and Zotero might help?

    p.s. I updated both and it still does not work.
  • Just to note, this is strictly a LibreOffice bug. The ReferenceMark feature we use to store Zotero citations is also used by native LibreOffice features as well as other plugins and there's no reason to believe only Zotero ReferenceMarks would be broken here. Updating LibreOffice is worth a shot.

    Otherwise, you have to say more than "that did not work". What did you try? Did copying text with citations from that document break them? Did you copy the full text of the document? Have you tried copying smaller snippets?
  • edited April 19, 2022
    Ok, I will also contact LibreOffice to see if they can offer a solution. I updated both LibreOffice and Zotero, but that did not change anything.

    With "that did not work" I was referring to the latest instruction " to just copy the contents of the broken document out into a fresh working one." I also tried copying only smaller snippets. As I wrote before, the citations in the proofread document look normal (grey underlining and the link appears when I place the cursor on them). As soon as I copy text (including the footnotes with citations in them) from the proofread document to my long document (300 pages), the citations are gone and there is only plain text left where the citations were (in the footnotes). I also tried to copy the text from both documents (proofread and 300-pages) into new documents and to work with those, but that did not help either. I really don't know what else to try.
  • I now seem to face an additional problem: since I updated both Zotero and LibreOffice the zotero toolbar inside LibreOffice does not react any more. I checked, and the Zotero Libre Office Integration seems to be active. The only thing I remember from the past that could be the problem is the JAVA surrounding. I went into the setting and will attach two screenshots. Maybe you can tell me what to do, in order to at least be able to add/edit citations again.

    Thank you!
  • p.s. Is there an option here to attach/send you a screen shot?
  • For screenshot, upload to a free image hosting site (imgur.com, dropbox, etc.) and link to from here
  • edited April 19, 2022
    Thank you (both for the link and the last info).
    I reinstalled the ZoteroLibreOfficeIntegration manually (first step) and checked that the JDK was selected (second step; now, the citation placeholder at least appears, I am still waiting for it to turn into the actual citation, hoping that this will take some time but eventually work...). However, these two steps seem to be necessary after EVERY (LibreOffice or Zotero) update, which is why I was avoiding updates in the past.
    Is that normal?

    My other problem (see above) is now dealt with in a LibreOffice-Forum, without any positive results so far.
  • edited April 19, 2022
    No, not normal. As a troubleshooting step, you might want to try moving your LO profile folder out of the way and starting with a fresh one. I don't think we've heard of this happening before but wiping that folder can fix random installation errors in LO.
  • Thank you, I will eventually try that thing with the profile folder. Even though no solution was found I want to thank you for now for trying to help me out.
  • Also, every issue you've described in this thread are LibreOffice issues. None of them would have been caused by updating Zotero. LibreOffice Java JDK preferences shouldn't get reset upon LibreOffice update, but they might if your JDK is installed in a non-standard location or is very old.
  • Ok, good to know. Since I have been working with Zotero and LibreOffice for years I wonder if my long document would get messed up (formatting-wise, and of course regarding the citations) if I would switch to Word (from LibreOffice). Do you think, that would make sense at this advanced stage or would it put my document at risk?
  • Formatting does tend to get affected when switching from LibreOffice to Word. You usually can transfer Zotero citations from LibreOffice to Word without issues, but that's assuming the underlying document doesn't have any problems. Either way it cannot hurt to try. See https://www.zotero.org/support/kb/moving_documents_between_word_processors#word_and_libreoffice
Sign In or Register to comment.