attach files


since 2.0b7.4 on linux i have a problem: I can not attach a file.

Most articles i get from pubmed. Then i get to the source of the article and download the pdf. Before this version i was nearly every time able to drag the link on the citation and zotero downloaded the file automatically and attached it. Now it doesn't... no matter what site. Then i tryed to make the old way which also worked until now: i downloaded the file and said then "attach stored copy of file". But this also don't works now: There is no file attached after i added it.

What still works is when the site of the article is supported by zotero... then the file is correctly downloaded and attached. But the problem is that not all sites are supported and generally i prefer to store the citation from pubmed because in many cases it is better.

Do you need any log files or so on? Please tell me if so.

  • I can confirm this problems as well. I am simply not able to attach a file which is not on the net. I have several files that i have stored on my computer and would like to add to the zotero library. I have tried odt, pdf, docx and none of them worked.
    Here is my config:
    zotero 2.0b7.4
    firefox 3.5.4
    openSUSE 11.2 32bit with KDE 4.3.1 release 6
    Linux kernel
  • It still works on Ubuntu 9.10 (i.e. gnome). As a workaround for pdfs - can you open them in the adobe FF plugin? You can then add the pdf by using the "create new item" or "attach snapshot" function(s).
  • @adamsmith - yes, that would be a work around for pdf, however i have a whole lot of other files (mostly documents and spreadsheets).
    i also tried another workaround - i opened the folder containing the files in FF (file:///etc.) then i dragged the link to the file into zotero and it worked. At this point however, I think my FF went dead: i could not open any page - only google would open. at the same time konqueror (the native KDE browser) was working fine. a lot of other anomalies occurred but dont have the time to describe them now. reboot did not help. i had to reinstall FF in order for it to work again.
    right now i need my browser and zotero so i will not try to see if i can replicate the problem.
  • zinaf: It's not really clear to me what the problem is that you're describing—you don't really provide any details—but it might be this OpenSUSE/KDE issue.
  • Dear Dan, i realise that i did not provide much details, and YES it is the same problem as the one you point. I went trough many threads on the forums but did not come across that one.
    anyway from what i can see there, it appears that this is a specific suse-kde-firefox issue and not zotero's
    i also came up with the same workaround as described at that thread. for me though it might have caused ff to crash as it stopped working after that. i had to reinstall. again this does not seem to be zotero related, i guess just zotero brings to the surface some issues in the ff-kde integration . :))
Sign In or Register to comment.