Restarted but still not syncing--"The file 'Desktop DB' In use"

Error Report ID: 1470162329

JavaScript Error: "unlabeled break must be inside loop or switch" {file: "chrome://skype_ff_toolbar_win/content/nh.js" line: 453 column: 62 source: " if (str.charAt(i).match(/[^;=!@#$%^&*()_+/\\ ,.~`\"|:-]/)) break;

[JavaScript Error: "[Exception... "'The file 'Desktop DB' is in use and cannot be updated. Please close the file or restart your computer and try syncing again.' when calling method: [nsIWebProgressListener::onStateChange]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]"]

[JavaScript Error: "Location is null" {file: "chrome://skype_ff_toolbar_win/content/tb.js" line: 4776}]

I did restart my computer and it still is not syncing. Help!

  • Not sure what that file is—"Desktop DB" was an old Mac OS (pre-OS X) system file, though the name might be used by some Windows program too. Have you tried closing all other open applications on your system (in case any start automatically after restarting)?

    If you generate debug output for the sync attempt from the Advanced pane of the Zotero prefs, submit it to the server, and post the Debug ID here, we might be able to find out more.
  • Here you go Dan: Debug output. Same problem today. Would it work to just delete that program "desktop db"? Or perhaps I need to update something?

    Thanks for your help!

    Report ID: 1537473379

    Debug Output:

    (4)(+0000000): Registering observer for [collection,search,share,group,bucket] in notifier with hash dA'

    (5)(+0000002): SELECT itemTypeID AS id, typeName AS name FROM itemTypes WHERE display=2 ORDER BY typeName

    (5)(+0000001): SELECT itemTypeID AS id, typeName AS name FROM itemTypes WHERE display=1 ORDER BY typeName
  • You need to enable debug output, perform a sync, and then send in the output.

    But yes, you can certainly try just deleting Delete DB. What else is in the folder it's in?
  • There is nothing else in the folder. Just it. I will redo the debug output. Thanks!
  • The Debug ID is D1885392837

    I sent the debug output and here is the ID
  • Actually, this is at least partially a bug that's already been fixed. The fix will be included in 2.0b7.5. Deleting Desktop DB should help in the meantime, though.
  • Hi there,

    I'm having the same issue with a PDF file from my collection.

    "The file 'FL600_Quantitation_of_Grn_Fluorescent_Proteins_in_Microplates.pdf' is in use and cannot be updated. Please close the file or restart your computer and try syncing again."

    I've tried removing the entry from my library but didn't help. I've submitted the error under ID 2083380043.

  • You shouldn't need to remove anything. As the message says, you should be able to close the file (and any other open PDFs, since you're just getting the same message about other files). If you're still getting it after you think you've closed everything, restart your computer.
  • See that's the problem - I don't have any of those files open on my workstation! I can synchronize the library just fine on a separate Mac I regularly use but not on this PC. I've tried restarting it already and didn't help. Then I tried removing that entry from the local library - it's gone but still gives me the above sync error.
  • Actually, the answer is most likely the same as I told Taylor above. It's a bug that's already been fixed, and the fix will be included in 2.0b7.5.
    I tried removing that entry from the local library - it's gone but still gives me the above sync error
    I suspect you didn't empty the Zotero trash folder, but, again, you shouldn't need to remove anything from Zotero. Deleting the file from disk should be a workaround, but this may happen for a number of files, and so you might want to just wait for 2.0b7.5.
  • Hi there,

    Problem not solved for me after an update to 2.0b7.5
    Report ID 2093476031
    Thanks for your input!

  • xtizon: Are you sure you don't have that file open? Have you tried restarting your computer?
  • Just restarted and the problem is still there. The file is not open from elsewhere.

  • OK, I may have fixed this, but, since I'm not able to reproduce the problem, I can't test it. If someone wants to try the latest trunk XPI and let us know if the problem is fixed, that'd be great. The warnings regarding the trunk XPI don't really apply at the moment, since the trunk has only a few changes since 2.0b7.5—all bug fixes—and will be released as 2.0b7.6 later tonight. (Obviously, whether or not you try the trunk, you should make sure you have a backup of your Zotero data directory.) If you do try the trunk, just be sure to switch back to 2.0b7.6 when it comes out.
  • Dan:

    I have the same problem as others.

    I had used Zotero 1.0 for a while, and grew quite a large library (>1 gb) of pdfs. I had switched to Zotero 2.0 about 2 months ago for some group work, and like it very much. I have just set up WebDav on a server that I mess around with, and am trying to upload all of my pdfs to that server.

    In this process, I get the same error message that others have received. I do not have any pdf program open, have restarted the computer and nothing helps. I have deleted the file in question, but Zotero just gets stuck on the next file that it encounters.

    I have not tried the trunk XPI, as you message indicating that it was safe is slightly dated.

    Here is the error code:

    [JavaScript Error: "[Exception... "'Trying to update finished request null/2D8FMMQK in Zotero.Sync.Storage.Request.onProgress()' when calling method: [nsIProgressEventSink::onProgress]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]"]
  • I should probably also add that I have successfully uploaded other files to the WebDav server space that I am using from the same Zotero account that I am having problems with.
  • edited December 6, 2009
    jmoyer: Can you provide a Debug ID for the sync attempt?

    Also, as my post above notes, the (possible) fix was included in 2.0b7.6, so there's no need to use the trunk.
  • Please follow my link. That's a Report ID, not a Debug ID.
  • D437253715

    Woops. My bad.
  • Dan: I don't know if this is any more use, but when I go to work and try to sync my zotero account I get this error: Unexpected file upload status 401 in Zotero.Sync.Storage._onUploadComplete()

    The Debug ID is D1355699186
  • Dan: Is this a problem that should be addressed from a development perspective, or am I doing something wrong?
  • edited December 15, 2009
    I'm not seeing any reason why this issue should still exist in 2.0b7.6 unless something else is actually using the file. If you're still experiencing the problem, you can try a utility such as Unlocker to see what's holding a lock on the file in question. (I haven't tried that utility and can't vouch for it, but others have mentioned it.)

    If you try it, let us know what it says. Be sure to restart your computer first.
  • Oh sorry. Thanks for your help. I did not see this question. I have downloaded the software, and am now seeing how it works....
  • Hi...

    I seem to have this same problem: "The file (file name) is in use and cannot be updated." with the recommendation that I close the file or restart my computer. I've restarted the computer and the file isn't open. I've also tried deleting it, but the error persists.


    Thank you muchly.

  • edited February 10, 2010
    I'm experiencing the same problem with a PDF in my library. You mentioned Unlocker, which I can vouch for and highly recommend, but it doesn't seem to work with Windows 7 (yet), and I recently upgraded, so I can't even try that.

    I did restart my computer but am getting the same message. Also, my library auto-syncs every few minutes and the status bar says it's downloading 7 files, even though everything should be synced. Any changes I made locally would be uploads, not downloads. (I'm not sure if this has anything to do with the many duplicates I just found in my library). I think this sync may be getting interrupted each time because of the sticky PDF that it thinks is open.

    UPDATE: after saving a copy of the PDF elsewhere on my hard drive, I deleted the PDF and its parent item from my library, emptied the trash, and the sync went fine. Interestingly, the status said it was downloading 6 files- before I deleted the PDF it kept trying to download 7.

    But now a new issue came out of this: I searched online and re-added the citation to my library. I went to "attach stored copy of file" intending to attach the copy I'd backed up before deleting, but the "select a file" window showed a copy of the file in a Zotero storage folder, with no other files. I selected it and it was attached to my re-added library item, in its own storage folder.

    Where did this unattached copy come from? What happens if I delete its Zotero storage folder? Does that mess up my database ("check database integrity" currently reports no errors)?
  • edited February 10, 2010
    Do you have anti-virus software installed? If so, disable it and try again.
Sign In or Register to comment.